summaryrefslogtreecommitdiffstats
path: root/academic/gmsh
diff options
context:
space:
mode:
author Fellype do Nascimento2020-02-15 23:24:02 +0100
committer Willy Sudiarto Raharjo2020-02-15 23:24:02 +0100
commit6c9c06de67d67f3574ec3b5ba9093bb59ea10d0d (patch)
treea0a2c29824cbc502d0358f2844a112bbea7b3ad1 /academic/gmsh
parent048869721a6970826bffdf2705935f9e0587c568 (diff)
downloadslackbuilds-6c9c06de67d67f3574ec3b5ba9093bb59ea10d0d.tar.gz
academic/gmsh: Added (Finite Element Mesh Generator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/gmsh')
-rw-r--r--academic/gmsh/README7
-rw-r--r--academic/gmsh/gmsh.SlackBuild115
-rw-r--r--academic/gmsh/gmsh.desktop10
-rw-r--r--academic/gmsh/gmsh.info10
-rw-r--r--academic/gmsh/slack-desc19
5 files changed, 161 insertions, 0 deletions
diff --git a/academic/gmsh/README b/academic/gmsh/README
new file mode 100644
index 0000000000..4414b6009d
--- /dev/null
+++ b/academic/gmsh/README
@@ -0,0 +1,7 @@
+Gmsh (A three-dimensional finite element mesh generator with built-in pre- and post-processing facilities)
+
+Gmsh is an open source 3D finite element mesh generator with a built-in CAD engine and post-processor. Its design goal is to provide a fast, light and user-friendly meshing tool with parametric input and advanced visualization capabilities. Gmsh is built around four modules: geometry, mesh, solver and post-processing. The specification of any input to these modules is done either interactively using the graphical user interface, in ASCII text files using Gmsh's own scripting language (.geo files), or using the C++, C, Python or Julia Application Programming Interface (API).
+
+See this general presentation for a high-level overview of Gmsh and recent developments, the screencasts for a quick tour of Gmsh's graphical user interface, and the reference manual for a more thorough overview of Gmsh's capabilities, some frequently asked questions and the documentation of the C++, C, Python and Julia API.
+
+The source code repository contains many examples written using both the built-in script language (see e.g. the tutorials and demos) and the API.
diff --git a/academic/gmsh/gmsh.SlackBuild b/academic/gmsh/gmsh.SlackBuild
new file mode 100644
index 0000000000..b56488e326
--- /dev/null
+++ b/academic/gmsh/gmsh.SlackBuild
@@ -0,0 +1,115 @@
+#!/bin/sh
+
+# Slackware build script for gmsh
+# Copyright 2020 Fellype do Nascimento, Campinas, Brazil
+#
+# Based on SlackBuild by Loris Vincenzi and PKGBUILD for gmsh at AUR
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gmsh
+VERSION=${VERSION:-4.5.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O3 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION-source
+tar -xzvf $CWD/$PRGNAM-$VERSION-source.tgz
+cd $PRGNAM-$VERSION-source
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir build
+cd build
+cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_DOCDIR:PATH=/usr/share/gmsh \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DENABLE_BUILD_SHARED=ON \
+ -DENABLE_PETSC=OFF \
+ -DENABLE_SLEPC=OFF \
+ ..
+# only demos/ and tutorial/ folders will be leaved in the /usr/share/gmsh dir
+
+make
+make install DESTDIR=$PKG
+cd -
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+install -d "$PKG/usr/share/pixmaps/$PRGNAM"
+install -m644 utils/icons/*.png "$PKG/usr/share/pixmaps/$PRGNAM"
+install -D -m644 utils/icons/solid_32x32.png "$PKG/usr/share/icons/$PRGNAM.png"
+install -D -m644 utils/icons/$PRGNAM.svg "$PKG/usr/share/icons/hicolor/scalable/apps/$PRGNAM.svg"
+
+desktop-file-install --dir="$PKG/usr/share/applications" "$CWD/$PRGNAM.desktop"
+
+mkdir -p $PKG/usr/man/man1
+mv $PKG/usr/share/man/man1/gmsh.1 $PKG/usr/man/man1/
+rm -Rf $PKG/usr/share/man/
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.txt CREDITS.txt LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm $PKG/usr/share/gmsh/*.txt
+rm -Rf $PKG/tmp
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/gmsh/gmsh.desktop b/academic/gmsh/gmsh.desktop
new file mode 100644
index 0000000000..ad08eb309c
--- /dev/null
+++ b/academic/gmsh/gmsh.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Gmsh
+Comment=Automatic 3D finite element mesh generator
+Icon=gmsh
+Exec=gmsh
+Encoding=UTF-8
+Terminal=false
+Type=Application
+Categories=Education;Science;Math;
diff --git a/academic/gmsh/gmsh.info b/academic/gmsh/gmsh.info
new file mode 100644
index 0000000000..339e53af7c
--- /dev/null
+++ b/academic/gmsh/gmsh.info
@@ -0,0 +1,10 @@
+PRGNAM="gmsh"
+VERSION="4.5.2"
+HOMEPAGE="http://gmsh.info/"
+DOWNLOAD="http://gmsh.info/src/gmsh-4.5.2-source.tgz"
+MD5SUM="4d5f211e6dc295d8ee0dea4c00f0323d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="fltk lapack med OpenCASCADE"
+MAINTAINER="Fellype do Nascimento"
+EMAIL="fellype (at) gmail (dot) com"
diff --git a/academic/gmsh/slack-desc b/academic/gmsh/slack-desc
new file mode 100644
index 0000000000..f88f19320c
--- /dev/null
+++ b/academic/gmsh/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler---------------------------------------------------------|
+gmsh: gmsh (finite element mesh generator)
+gmsh:
+gmsh: Gmsh is an automatic three-dimensional finite element mesh generator
+gmsh: with built-in pre- and post-processing facilities.
+gmsh:
+gmsh: Gmsh is copyright (C) 1997-2019 C. Geuzaine and J.-F. Remacle, and is
+gmsh: distributed under the terms of the GNU General Public License, Version 2
+gmsh: or later, with an exception to allow for easier linking with external
+gmsh: libraries.
+gmsh:
+gmsh: