summaryrefslogtreecommitdiffstats
path: root/academic/bibus/bibus.SlackBuild
diff options
context:
space:
mode:
author Ryan P.C. McQuen2014-05-04 05:52:53 +0200
committer Willy Sudiarto Raharjo2014-05-04 05:52:53 +0200
commit2d65a7e61bb9a9537adb086c4f341d38c398401c (patch)
tree2dc88774b5f2df36e437c1cad9620276fd9fc936 /academic/bibus/bibus.SlackBuild
parentae59dc0313102d1b6022bb078596fbef4e9a644f (diff)
downloadslackbuilds-2d65a7e61bb9a9537adb086c4f341d38c398401c.tar.gz
academic/bibus: Updated for version 1.5.2 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/bibus/bibus.SlackBuild')
-rw-r--r--academic/bibus/bibus.SlackBuild58
1 files changed, 38 insertions, 20 deletions
diff --git a/academic/bibus/bibus.SlackBuild b/academic/bibus/bibus.SlackBuild
index 97071bab94..c8c1bf95ff 100644
--- a/academic/bibus/bibus.SlackBuild
+++ b/academic/bibus/bibus.SlackBuild
@@ -3,12 +3,31 @@
# Slackware build script for bibus
# Written by David Miller dave@frop.net
-# This script is released into the public domain
-
# Modified by the SlackBuilds.org project
+# Rewritten by Ryan P.C. McQuen
+# Copyright 2014 Ryan P.C. McQuen, WA, ryan.q@linux.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
PRGNAM=bibus
-VERSION=${VERSION:-1.5.1}
+VERSION=${VERSION:-1.5.2}
ARCH=noarch
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -24,36 +43,35 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Patch the Makefile to install to PKGDIR
-patch -p1 < $CWD/Makefile.patch
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make \
PKGDIR=$PKG \
- DESTDIR=/usr \
- mandir=/usr/man \
- sysconfdir=/etc \
- docdir=/usr/doc/$PRGNAM-$VERSION \
- oopath=/opt/openoffice.org3/program \
- ooure=/opt/openoffice.org3/basis-link/ure-link/lib \
- oobasis=/opt/openoffice.org3/basis-link/program
+ DESTDIR=$PKG/usr \
+ mandir=$PKG/usr/man \
+ sysconfdir=$PKG/etc \
+ docdir=$PKG/usr/doc/$PRGNAM-$VERSION \
+ oopath=$PKG/opt/openoffice4/program \
+ ooure=$PKG/opt/openoffice4/basis-link/ure-link/lib \
+ oobasis=$PKG/opt/openoffice4/basis-link/program
# Don't clobber the config file
mv $PKG/etc/bibus.config $PKG/etc/bibus.config.new
-
-( cd $PKG/usr/man
+(
+ cd $PKG/usr/man/
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
+rm -f $PKG/usr/share/bibus/*/*.{csv,py}~
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a -r Docs/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild