summaryrefslogtreecommitdiffstats
path: root/academic/abntex/abntex.SlackBuild
diff options
context:
space:
mode:
author Andre Barboza2010-05-12 23:27:35 +0200
committer Robby Workman2010-05-12 23:27:35 +0200
commitc3fb778f2698f35b69e46d01357c9138c9817e8f (patch)
treec68a9c6bd8c7119b1cecd78f666c081632399d05 /academic/abntex/abntex.SlackBuild
parent12627a9ec0db47b4cbde20c4cd85ce0a10d7cc3c (diff)
downloadslackbuilds-c3fb778f2698f35b69e46d01357c9138c9817e8f.tar.gz
academic/abntex: Added to 12.2 repository
Diffstat (limited to 'academic/abntex/abntex.SlackBuild')
-rw-r--r--academic/abntex/abntex.SlackBuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/academic/abntex/abntex.SlackBuild b/academic/abntex/abntex.SlackBuild
new file mode 100644
index 0000000000..3df10fce1e
--- /dev/null
+++ b/academic/abntex/abntex.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for abntex
+
+# Copyright 2009 Andre Barboza <bmg.andre@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Slightly modified by Robby Workman <rworkman@slackbuilds.org>
+
+PRGNAM=abntex
+VERSION=${VERSION:-0.9_beta2}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+MAJOR=$(echo $VERSION | cut -d _ -f 1)
+MINOR=$(echo $VERSION | cut -d _ -f 2)
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+FORCE_LYX=${FORCE_LYX:-NO}
+LYX_PATH=${LYX_PATH:-/usr/share/lyx}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$MAJOR
+tar xvf $CWD/$PRGNAM-$MAJOR-$MINOR.tar.gz
+cd $PRGNAM-$MAJOR
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch < $CWD/Makefile.diff
+
+find texmf/ lyx/ -type f -exec chmod 644 {} \;
+
+echo quit | make doc
+make install DESTDIR=$PKG
+
+# Lyx may not have been installed
+if [ "$FORCE_LYX" != "NO" ]; then
+ mkdir -p $PKG/usr/share/lyx
+ cp -rf lyx/layouts/ $PKG/$LYX_PATH
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LEIAME LEIAME.administracao LEIAME.linux compiled.docs/* lyx/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz