summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2021-02-18 21:06:32 +0100
committer Willy Sudiarto Raharjo2021-02-20 18:05:11 +0100
commitf4c418d6bb99f5cb80a0aea08ce3b3dee5397e1e (patch)
treec38b1b7538b8027cbdb80c253d52de921e91506e
parent4e92e75cac0a61c4b272df65dbf89d6a05d2563b (diff)
downloadslackbuilds-f4c418d6bb99f5cb80a0aea08ce3b3dee5397e1e.tar.gz
python/testpath: Fix install dir.
Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/testpath/setup.py13
-rw-r--r--python/testpath/testpath.SlackBuild5
-rw-r--r--python/testpath/testpath.info4
3 files changed, 4 insertions, 18 deletions
diff --git a/python/testpath/setup.py b/python/testpath/setup.py
deleted file mode 100644
index 3a92914bf1..0000000000
--- a/python/testpath/setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
-
-from setuptools import setup, find_packages
-
-setup(
- name='testpath',
- version='0.4.1',
- description='Test utilities for Python code working with files and commands',
- url='https://github.com/jupyter/testpath',
- author='The Jupyter Development Team',
- license='MIT',
- long_description='Test utilities for Python code working with files and commands',
- packages=find_packages(exclude=['tests'])
-)
diff --git a/python/testpath/testpath.SlackBuild b/python/testpath/testpath.SlackBuild
index 3a8e585db1..daaa3e08bd 100644
--- a/python/testpath/testpath.SlackBuild
+++ b/python/testpath/testpath.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for testpath
-# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=testpath
VERSION=${VERSION:-0.4.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cp $CWD/setup.py .
python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
diff --git a/python/testpath/testpath.info b/python/testpath/testpath.info
index b037a7c944..3880ba0d0c 100644
--- a/python/testpath/testpath.info
+++ b/python/testpath/testpath.info
@@ -1,8 +1,8 @@
PRGNAM="testpath"
VERSION="0.4.4"
HOMEPAGE="https://github.com/jupyter/testpath"
-DOWNLOAD="https://github.com/jupyter/testpath/archive/0.4.4/testpath-0.4.4.tar.gz"
-MD5SUM="4d7795541fccebd2be9818aead36caf1"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/testpath/testpath-0.4.4.tar.gz"
+MD5SUM="297100d49a6f20859383434a182cf426"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3"