summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author nomnombtc2021-04-10 01:54:23 +0200
committer Willy Sudiarto Raharjo2021-04-10 12:04:41 +0200
commitebba7f34c2fbd198d6b5e5a95aa24218e8afb44f (patch)
tree1a561896fa0e8b49f7880cf3b6ee229cb078d8c4
parenta6f8b97014988733ccb7c1bbbb0a9617bf91636c (diff)
downloadslackbuilds-ebba7f34c2fbd198d6b5e5a95aa24218e8afb44f.tar.gz
python/python3-aiorpcX-legacy: Added (async RPC implementation)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-aiorpcX-legacy/README10
-rw-r--r--python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild87
-rw-r--r--python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info10
-rw-r--r--python/python3-aiorpcX-legacy/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python3-aiorpcX-legacy/README b/python/python3-aiorpcX-legacy/README
new file mode 100644
index 0000000000..3de43160bd
--- /dev/null
+++ b/python/python3-aiorpcX-legacy/README
@@ -0,0 +1,10 @@
+aiorpcX is a generic asyncio library implementation of RPC suitable
+for an application that is a client, server or both.
+
+NOTE:
+This is an older version of the program, kept here for compatibility
+with Electrum.
+
+IMPORTANT:
+This package conflicts with python3-aiorpcX, python3-aiorpcX-legacy
+and python3-aiorpcX cannot both be installed at the same time.
diff --git a/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild b/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild
new file mode 100644
index 0000000000..cbaef9452d
--- /dev/null
+++ b/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python3-aiorpcX-legacy
+# Copyright 2019-2021 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2021 nomnombtc <nomnombtc@arcor.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-aiorpcX-legacy
+VERSION=${VERSION:-0.18.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=aiorpcX
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/ LICENCE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info b/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info
new file mode 100644
index 0000000000..e4aca61d3c
--- /dev/null
+++ b/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-aiorpcX-legacy"
+VERSION="0.18.7"
+HOMEPAGE="https://aiorpcx.readthedocs.io/en/stable/"
+DOWNLOAD="https://github.com/kyuupichan/aiorpcX/archive/0.18.7/aiorpcX-0.18.7.tar.gz"
+MD5SUM="8349fdc8ad6bfb37174ae24b444d8485"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-attrs"
+MAINTAINER="nomnombtc"
+EMAIL="nomnombtc@arcor.de"
diff --git a/python/python3-aiorpcX-legacy/slack-desc b/python/python3-aiorpcX-legacy/slack-desc
new file mode 100644
index 0000000000..607ffe6a83
--- /dev/null
+++ b/python/python3-aiorpcX-legacy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-aiorpcX-legacy: python3-aiorpcX-legacy (Generic async RPC implementation)
+python3-aiorpcX-legacy:
+python3-aiorpcX-legacy: aiorpcX is a generic asyncio library implementation of RPC suitable
+python3-aiorpcX-legacy: for an application that is a client, server or both.
+python3-aiorpcX-legacy:
+python3-aiorpcX-legacy: https://aiorpcx.readthedocs.io/en/stable/
+python3-aiorpcX-legacy:
+python3-aiorpcX-legacy:
+python3-aiorpcX-legacy:
+python3-aiorpcX-legacy:
+python3-aiorpcX-legacy: