summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author MDrights2020-05-22 20:33:09 +0200
committer Willy Sudiarto Raharjo2020-05-23 04:32:00 +0200
commitcf24c4fc2bb1c1337e00731172a98fc6d1235802 (patch)
tree26cf790d98b0c0e72ae40b6062f5141c46718064
parentb4a8d5b75b65654f3c382ac3b6ea30ca66130034 (diff)
downloadslackbuilds-cf24c4fc2bb1c1337e00731172a98fc6d1235802.tar.gz
python/python3-Flask-httpauth: Added (Extension for Python3-Flask)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-Flask-httpauth/README2
-rw-r--r--python/python3-Flask-httpauth/python3-Flask-httpauth.SlackBuild87
-rw-r--r--python/python3-Flask-httpauth/python3-Flask-httpauth.info10
-rw-r--r--python/python3-Flask-httpauth/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/python3-Flask-httpauth/README b/python/python3-Flask-httpauth/README
new file mode 100644
index 0000000000..f64ff30737
--- /dev/null
+++ b/python/python3-Flask-httpauth/README
@@ -0,0 +1,2 @@
+Simple extension that provides Basic and Digest HTTP authentication for Flask
+routes.
diff --git a/python/python3-Flask-httpauth/python3-Flask-httpauth.SlackBuild b/python/python3-Flask-httpauth/python3-Flask-httpauth.SlackBuild
new file mode 100644
index 0000000000..cf72df25a3
--- /dev/null
+++ b/python/python3-Flask-httpauth/python3-Flask-httpauth.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python3-Flask-httpauth
+
+# Copyright 2019 MDrights <psychi2009@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-Flask-httpauth
+PROGNAM=Flask-HTTPAuth
+VERSION=${VERSION:-3.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PROGNAM-$VERSION
+tar xvf $CWD/$PROGNAM-$VERSION.tar.gz
+cd $PROGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO docs/*.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-Flask-httpauth/python3-Flask-httpauth.info b/python/python3-Flask-httpauth/python3-Flask-httpauth.info
new file mode 100644
index 0000000000..25fdb3ae08
--- /dev/null
+++ b/python/python3-Flask-httpauth/python3-Flask-httpauth.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-Flask-httpauth"
+VERSION="3.3.0"
+HOMEPAGE="https://github.com/miguelgrinberg/flask-httpauth/"
+DOWNLOAD="https://files.pythonhosted.org/packages/e0/95/798367396accd78a9cc7976345da7c7eed48b8e3666307839ea9e7e82890/Flask-HTTPAuth-3.3.0.tar.gz"
+MD5SUM="0ec5abc78e2fbb4cc624011c9f60d2ee"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-Flask"
+MAINTAINER="MDrights"
+EMAIL="psychi2009@gmail.com"
diff --git a/python/python3-Flask-httpauth/slack-desc b/python/python3-Flask-httpauth/slack-desc
new file mode 100644
index 0000000000..085314f633
--- /dev/null
+++ b/python/python3-Flask-httpauth/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-Flask-httpauth: python3-Flask-httpauth (Extension for Python3-Flask)
+python3-Flask-httpauth:
+python3-Flask-httpauth: Simple extension that provides Basic and Digest HTTP
+python3-Flask-httpauth: authentication for Flask routes.
+python3-Flask-httpauth:
+python3-Flask-httpauth: Homepage:
+python3-Flask-httpauth: https://github.com/miguelgrinberg/flask-httpauth/
+python3-Flask-httpauth:
+python3-Flask-httpauth:
+python3-Flask-httpauth:
+python3-Flask-httpauth: