summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2017-09-19 06:29:46 +0200
committer David Spencer2017-09-23 17:33:49 +0200
commitc9bcfd5b7d0b29bc5d59bac9d76149d743da6cf9 (patch)
tree747970ea25b62cde29d8d65518da98691872f4c1
parent87cab4299a100b2cadc861b0bcac17ea344678e4 (diff)
downloadslackbuilds-c9bcfd5b7d0b29bc5d59bac9d76149d743da6cf9.tar.gz
python/six: Updated for version 1.11.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--python/six/README6
-rw-r--r--python/six/six.SlackBuild10
-rw-r--r--python/six/six.info6
3 files changed, 7 insertions, 15 deletions
diff --git a/python/six/README b/python/six/README
index e968d08d27..e995a974e8 100644
--- a/python/six/README
+++ b/python/six/README
@@ -3,8 +3,4 @@ smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
-Optional dependencies: python3 and Sphinx
-
-Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
-
- # PYTHON3=yes ./six.SlackBuild
+Optional dependencies: Sphinx
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
index 69506ba6cc..f4f61c16ca 100644
--- a/python/six/six.SlackBuild
+++ b/python/six/six.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for six
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=six
-VERSION=${VERSION:-1.10.0}
+VERSION=${VERSION:-1.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,10 +57,6 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -72,7 +68,7 @@ if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
[ -d documentation/_build/singlehtml ] && \
cp -a documentation/_build/singlehtml/index.html \
documentation/_build/singlehtml/_static \
diff --git a/python/six/six.info b/python/six/six.info
index ac1dfc2093..32ec3507b7 100644
--- a/python/six/six.info
+++ b/python/six/six.info
@@ -1,8 +1,8 @@
PRGNAM="six"
-VERSION="1.10.0"
+VERSION="1.11.0"
HOMEPAGE="https://pypi.python.org/pypi/six/"
-DOWNLOAD="https://pypi.python.org/packages/source/s/six/six-1.10.0.tar.gz"
-MD5SUM="34eed507548117b2ab523ab14b2f8b55"
+DOWNLOAD="https://pypi.python.org/packages/16/d8/bc6316cf98419719bd59c91742194c111b6f2e85abac88e496adefaf7afe/six-1.11.0.tar.gz"
+MD5SUM="d12789f9baf7e9fb2524c0c64f1773f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""