summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-23 16:58:18 +0100
committer Erik Hanson2014-01-30 06:21:11 +0100
commitbdcce84a3c96d12125377742322df4e6e95c23ef (patch)
tree8b1fd809acc4103889c9086e00ba72686732b09e
parentac38fa5624a6daea73775e5080e682e5f50d9574 (diff)
downloadslackbuilds-bdcce84a3c96d12125377742322df4e6e95c23ef.tar.gz
python/PyInstaller: Added (Converts Python programs).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/PyInstaller/PyInstaller.SlackBuild85
-rw-r--r--python/PyInstaller/PyInstaller.info10
-rw-r--r--python/PyInstaller/README6
-rw-r--r--python/PyInstaller/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/PyInstaller/PyInstaller.SlackBuild b/python/PyInstaller/PyInstaller.SlackBuild
new file mode 100644
index 0000000000..2a86e3fa9f
--- /dev/null
+++ b/python/PyInstaller/PyInstaller.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for PyInstaller
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PyInstaller
+VERSION=${VERSION:-2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/PyInstaller/PyInstaller.info b/python/PyInstaller/PyInstaller.info
new file mode 100644
index 0000000000..5f48c13cb7
--- /dev/null
+++ b/python/PyInstaller/PyInstaller.info
@@ -0,0 +1,10 @@
+PRGNAM="PyInstaller"
+VERSION="2.1"
+HOMEPAGE="http://www.pyinstaller.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/P/PyInstaller/PyInstaller-2.1.tar.gz"
+MD5SUM="248531f6fc94b0ffb02473321496d6d0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/PyInstaller/README b/python/PyInstaller/README
new file mode 100644
index 0000000000..0a45ff2318
--- /dev/null
+++ b/python/PyInstaller/README
@@ -0,0 +1,6 @@
+PyInstaller is a program that converts (packages) Python programs into
+stand-alone executables, under Windows, Linux, Mac OS X, Solaris and AIX.
+Its main advantages over similar tools are that PyInstaller works with
+any version of Python since 2.4, it builds smaller executables thanks to
+transparent compression, it is fully multi-platform, and use the OS support
+to load the dynamic libraries, thus ensuring full compatibility.
diff --git a/python/PyInstaller/slack-desc b/python/PyInstaller/slack-desc
new file mode 100644
index 0000000000..983ade4c5c
--- /dev/null
+++ b/python/PyInstaller/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyInstaller: PyInstaller (Converts Python programs)
+PyInstaller:
+PyInstaller: PyInstaller is a program that converts (packages) Python programs
+PyInstaller: into stand-alone executables, under Windows, Linux, Mac OS X, AIX
+PyInstaller: and Solaris.
+PyInstaller:
+PyInstaller: Homepage: http://www.pyinstaller.org/
+PyInstaller:
+PyInstaller:
+PyInstaller:
+PyInstaller: