summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-06 01:46:00 +0100
committer Erik Hanson2014-02-08 18:10:10 +0100
commitb00039c0fe9597c05d73ca0490c3d0436549409d (patch)
tree7824919946b96028153484c25536c41d6e5cf0ef
parent86d7a33d47c9228f214ec5dad1a0eff89960d1a3 (diff)
downloadslackbuilds-b00039c0fe9597c05d73ca0490c3d0436549409d.tar.gz
libraries/python-xlrd: Added (extract data from MS Excel).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/python-xlrd/README5
-rw-r--r--libraries/python-xlrd/python-xlrd.SlackBuild90
-rw-r--r--libraries/python-xlrd/python-xlrd.info10
-rw-r--r--libraries/python-xlrd/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/libraries/python-xlrd/README b/libraries/python-xlrd/README
new file mode 100644
index 0000000000..4cae318481
--- /dev/null
+++ b/libraries/python-xlrd/README
@@ -0,0 +1,5 @@
+Library for developers to extract data from Microsoft Excel files.
+
+Extract data from Excel spreadsheets (.xls and .xlsx, versions 2.0
+onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). Strong
+support for Excel dates. Unicode-aware.
diff --git a/libraries/python-xlrd/python-xlrd.SlackBuild b/libraries/python-xlrd/python-xlrd.SlackBuild
new file mode 100644
index 0000000000..2b164f64f0
--- /dev/null
+++ b/libraries/python-xlrd/python-xlrd.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for xlrd
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-xlrd
+SCRNAM=xlrd
+VERSION=${VERSION:-0.9.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SCRNAM-$VERSION
+tar xvf $CWD/$SCRNAM-$VERSION.tar.gz
+cd $SCRNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.html xlrd/doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-xlrd/python-xlrd.info b/libraries/python-xlrd/python-xlrd.info
new file mode 100644
index 0000000000..f541b680d1
--- /dev/null
+++ b/libraries/python-xlrd/python-xlrd.info
@@ -0,0 +1,10 @@
+PRGNAM="python-xlrd"
+VERSION="0.9.2"
+HOMEPAGE="http://www.python-excel.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/x/xlrd/xlrd-0.9.2.tar.gz"
+MD5SUM="91a81ee76233e9f3115acaaa1b251b0e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/python-xlrd/slack-desc b/libraries/python-xlrd/slack-desc
new file mode 100644
index 0000000000..6ccce05e0f
--- /dev/null
+++ b/libraries/python-xlrd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-xlrd: python-xlrd (Library to extract data from Microsoft Excel)
+python-xlrd:
+python-xlrd: Extract data from Excel spreadsheets (.xls and .xlsx, versions 2.0
+python-xlrd: onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). Strong
+python-xlrd: support for Excel dates. Unicode-aware.
+python-xlrd:
+python-xlrd: Homepage: http://www.python-excel.org/
+python-xlrd:
+python-xlrd:
+python-xlrd:
+python-xlrd: