summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Christopher Walker2013-05-05 09:30:08 +0200
committer Niels Horn2013-05-13 03:20:52 +0200
commit9fdc721a4f075f51fdcef80b8a99c364bd905aa2 (patch)
treedf3565b97e1372655d387fa3d91fee746dab63ce
parent645655708e8f5a3e24a5017b5e6d020948289910 (diff)
downloadslackbuilds-9fdc721a4f075f51fdcef80b8a99c364bd905aa2.tar.gz
development/gnustep-base: Added (GNUstep Base Library)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--development/gnustep-base/README10
-rw-r--r--development/gnustep-base/gnustep-base.SlackBuild95
-rw-r--r--development/gnustep-base/gnustep-base.info10
-rw-r--r--development/gnustep-base/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/development/gnustep-base/README b/development/gnustep-base/README
new file mode 100644
index 0000000000..bde6a5d34b
--- /dev/null
+++ b/development/gnustep-base/README
@@ -0,0 +1,10 @@
+GNUstep is a free, object-oriented, cross-platform development environment
+that strives for simplicity and elegance. GNUstep is based on and completely
+compatible with the OpenStep specification developed by NeXT (now Apple
+Computer Inc.) as well as implementing the extensions added by Apple in the
+form of Cocoa.
+
+This package contains GNUstep-base component of the core libraries needed to
+write non-graphic tools in Objective-C. It includes all of the classes
+necessary for writing an incredible array of tools, from wrappers for system
+tools to tools for communicating with web and other types of servers.
diff --git a/development/gnustep-base/gnustep-base.SlackBuild b/development/gnustep-base/gnustep-base.SlackBuild
new file mode 100644
index 0000000000..fc97b28901
--- /dev/null
+++ b/development/gnustep-base/gnustep-base.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for gnustep-base
+#
+# Copyright 2013 Christopher Walker Copperas Cove, TX
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gnustep-base
+VERSION=${VERSION:-1.24.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R a-s,u+rw,go+r-w .
+
+. /usr/share/GNUstep/Makefiles/GNUstep-reset.sh
+. /usr/share/GNUstep/Makefiles/GNUstep.sh
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --mandir=/usr/man \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --enable-ffcall \
+ --build=$ARCH-slackware-linux
+make
+make install DESTDIR=$PKG GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ANNOUNCE COPYING COPYING.LIB COPYINGv3 ChangeLog INSTALL NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/gnustep-base/gnustep-base.info b/development/gnustep-base/gnustep-base.info
new file mode 100644
index 0000000000..a4864e00ac
--- /dev/null
+++ b/development/gnustep-base/gnustep-base.info
@@ -0,0 +1,10 @@
+PRGNAM="gnustep-base"
+VERSION="1.24.3"
+HOMEPAGE="http://www.gnustep.org"
+DOWNLOAD="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-base-1.24.3.tar.gz"
+MD5SUM="57923f238d6af2cac8bda232e2284dd4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gnustep-make"
+MAINTAINER="Christopher Walker"
+EMAIL="kris240376@gmail.com"
diff --git a/development/gnustep-base/slack-desc b/development/gnustep-base/slack-desc
new file mode 100644
index 0000000000..265108f070
--- /dev/null
+++ b/development/gnustep-base/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gnustep-base: gnustep-base (GNUstep Base Library)
+gnustep-base:
+gnustep-base: The GNUstep Base Library is a library of general-purpose, non-
+gnustep-base: graphical Objective C objects. For example, it includes classes for
+gnustep-base: strings, object collections, byte streams, typed coders, invocations,
+gnustep-base: notifications, notification dispatchers, moments in time, network
+gnustep-base: ports, remote object messaging support (distributed objects), and
+gnustep-base: event loops.
+gnustep-base:
+gnustep-base: It provides functionality that aims to implement the non-graphical
+gnustep-base: portion of the Apple's Cocoa frameworks (the Foundation library).