summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-03-13 14:35:54 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:22 +0100
commit875ab70ef1333fae880aef6021302494677246e3 (patch)
tree490149aac00c8c84fb5fcef7a8012d9b41895e59
parent312a70bab26ffe713d85326d1b515197b19c2dde (diff)
downloadslackbuilds-875ab70ef1333fae880aef6021302494677246e3.tar.gz
python/python3-obspy: Added (A Python Framework for Seismology).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-obspy/README14
-rw-r--r--python/python3-obspy/python3-obspy.SlackBuild86
-rw-r--r--python/python3-obspy/python3-obspy.info10
-rw-r--r--python/python3-obspy/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/python/python3-obspy/README b/python/python3-obspy/README
new file mode 100644
index 0000000000..9a1475384c
--- /dev/null
+++ b/python/python3-obspy/README
@@ -0,0 +1,14 @@
+ObsPy is an open-source project dedicated to provide a Python
+framework for processing seismological data. It provides parsers
+for common file formats, clients to access data centers and
+seismological signal processing routines which allow the manipulation
+of seismological time series. The goal of the ObsPy project is to
+facilitate rapid application development for seismology.
+
+
+NOTES:
+
+suds-jurko must be built with python3 support.
+
+Generally speaking, all the indirect dependencies must be built
+with python3 support, where possible.
diff --git a/python/python3-obspy/python3-obspy.SlackBuild b/python/python3-obspy/python3-obspy.SlackBuild
new file mode 100644
index 0000000000..c1bf7385cb
--- /dev/null
+++ b/python/python3-obspy/python3-obspy.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python3-obspy
+
+# Copyright (c) 2019 Cristiano Urban, Gonars, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-obspy
+SRCNAM=obspy
+VERSION=${VERSION:-1.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.txt MANIFEST.in LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-obspy/python3-obspy.info b/python/python3-obspy/python3-obspy.info
new file mode 100644
index 0000000000..3b2a7a8a34
--- /dev/null
+++ b/python/python3-obspy/python3-obspy.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-obspy"
+VERSION="1.1.1"
+HOMEPAGE="https://github.com/obspy/obspy/wiki"
+DOWNLOAD="https://github.com/obspy/obspy/archive/1.1.1/obspy-1.1.1.tar.gz"
+MD5SUM="ae7b75055a1de926f80d4818a60a127c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-decorator python3-future python-requests scipy3 lxml SQLAlchemy python3-basemap suds-jurko"
+MAINTAINER="Cristiano Urban"
+EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/python/python3-obspy/slack-desc b/python/python3-obspy/slack-desc
new file mode 100644
index 0000000000..a730e787c1
--- /dev/null
+++ b/python/python3-obspy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-obspy: python3-obspy (A Python Framework for Seismology)
+python3-obspy:
+python3-obspy: ObsPy is an open-source project dedicated to provide a Python
+python3-obspy: framework for processing seismological data. It provides parsers
+python3-obspy: for common file formats, clients to access data centers and
+python3-obspy: seismological signal processing routines which allow the manipulation
+python3-obspy: of seismological time series. The goal of the ObsPy project is to
+python3-obspy: facilitate rapid application development for seismology.
+python3-obspy:
+python3-obspy: Homepage: https://github.com/obspy/obspy/wiki
+python3-obspy: