summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky2020-09-18 20:00:15 +0200
committer Willy Sudiarto Raharjo2020-09-18 20:00:15 +0200
commit64e6c76a4382e225c9ca28933594010509f25a53 (patch)
tree9be48533165a11d304d5028197dd8bdf53264dd4
parenta436d194f572e8ec475c4e2c6d1f2ff9d4179c4f (diff)
downloadslackbuilds-64e6c76a4382e225c9ca28933594010509f25a53.tar.gz
development/neovim-remote: Added (remote control for neovim).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/neovim-remote/README3
-rw-r--r--development/neovim-remote/doinst.sh14
-rw-r--r--development/neovim-remote/neovim-remote.SlackBuild89
-rw-r--r--development/neovim-remote/neovim-remote.info10
-rw-r--r--development/neovim-remote/slack-desc19
5 files changed, 135 insertions, 0 deletions
diff --git a/development/neovim-remote/README b/development/neovim-remote/README
new file mode 100644
index 0000000000..b2d9c28ded
--- /dev/null
+++ b/development/neovim-remote/README
@@ -0,0 +1,3 @@
+Control nvim processes using "nvr" commandline tool.
+
+Dependencies should be built with python3 support.
diff --git a/development/neovim-remote/doinst.sh b/development/neovim-remote/doinst.sh
new file mode 100644
index 0000000000..fc3cdc8518
--- /dev/null
+++ b/development/neovim-remote/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/bash_completion.d/neovim-remote.new
diff --git a/development/neovim-remote/neovim-remote.SlackBuild b/development/neovim-remote/neovim-remote.SlackBuild
new file mode 100644
index 0000000000..ff6e203f8f
--- /dev/null
+++ b/development/neovim-remote/neovim-remote.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for neovim-remote
+
+# Copyright 2020, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=neovim-remote
+VERSION=${VERSION:-2.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/etc/bash_completion.d
+cp contrib/completion.bash $PKG/etc/bash_completion.d/neovim-remote.new
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/neovim-remote/neovim-remote.info b/development/neovim-remote/neovim-remote.info
new file mode 100644
index 0000000000..2e84053d0d
--- /dev/null
+++ b/development/neovim-remote/neovim-remote.info
@@ -0,0 +1,10 @@
+PRGNAM="neovim-remote"
+VERSION="2.4.0"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+DOWNLOAD="https://github.com/mhinz/neovim-remote/archive/v2.4.0/neovim-remote-2.4.0.tar.gz"
+MD5SUM="c49c70b8f4725bf69aed152db62d593c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 python-neovim psutil"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/development/neovim-remote/slack-desc b/development/neovim-remote/slack-desc
new file mode 100644
index 0000000000..acf453de55
--- /dev/null
+++ b/development/neovim-remote/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+neovim-remote: neovim-remote (remote control for neovim)
+neovim-remote:
+neovim-remote: Control nvim processes using "nvr" commandline tool.
+neovim-remote:
+neovim-remote:
+neovim-remote: Homepage: https://github.com/mhinz/neovim-remote
+neovim-remote:
+neovim-remote:
+neovim-remote:
+neovim-remote:
+neovim-remote: