summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2022-01-11 19:04:15 +0100
committer Willy Sudiarto Raharjo2022-01-17 03:03:29 +0100
commit586754604ab1a355bb18b0dab674b53a5ed52e9d (patch)
tree93957ddf283105580194062983c0769aee5a4c78
parent7eed4f4162bcffa3b565470266a15e381e241d70 (diff)
downloadslackbuilds-586754604ab1a355bb18b0dab674b53a5ed52e9d.tar.gz
python/python3-sgmllib3k: Added (python3 port of python 2 sgmllib)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-sgmllib3k/README5
-rw-r--r--python/python3-sgmllib3k/python3-sgmllib3k.SlackBuild71
-rw-r--r--python/python3-sgmllib3k/python3-sgmllib3k.info10
-rw-r--r--python/python3-sgmllib3k/slack-desc19
4 files changed, 105 insertions, 0 deletions
diff --git a/python/python3-sgmllib3k/README b/python/python3-sgmllib3k/README
new file mode 100644
index 0000000000..0af3150eb0
--- /dev/null
+++ b/python/python3-sgmllib3k/README
@@ -0,0 +1,5 @@
+python3-sgmllib3k (python3 port of python 2 sgmllib)
+
+sgmllib was dropped in Python 3. For those depending on it, that's
+somewhat unfortunate. This is a quick and dirty port of this old
+module.
diff --git a/python/python3-sgmllib3k/python3-sgmllib3k.SlackBuild b/python/python3-sgmllib3k/python3-sgmllib3k.SlackBuild
new file mode 100644
index 0000000000..636b632c33
--- /dev/null
+++ b/python/python3-sgmllib3k/python3-sgmllib3k.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/bash
+
+# Slackware build script for sgmllib3k
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-sgmllib3k
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+SRCNAM="$( echo $PRGNAM | cut -d- -f2 )"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+python3 setup.py install --root $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-sgmllib3k/python3-sgmllib3k.info b/python/python3-sgmllib3k/python3-sgmllib3k.info
new file mode 100644
index 0000000000..905e7978f8
--- /dev/null
+++ b/python/python3-sgmllib3k/python3-sgmllib3k.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-sgmllib3k"
+VERSION="1.0.0"
+HOMEPAGE="https://pypi.org/project/sgmllib3k/"
+DOWNLOAD="https://files.pythonhosted.org/packages/9e/bd/3704a8c3e0942d711c1299ebf7b9091930adae6675d7c8f476a7ce48653c/sgmllib3k-1.0.0.tar.gz"
+MD5SUM="d70efde06e40797f37e867123aa080ec"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/python/python3-sgmllib3k/slack-desc b/python/python3-sgmllib3k/slack-desc
new file mode 100644
index 0000000000..fea96314e5
--- /dev/null
+++ b/python/python3-sgmllib3k/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-sgmllib3k: python3-sgmllib3k (python3 port of python 2 sgmllib)
+python3-sgmllib3k:
+python3-sgmllib3k: sgmllib was dropped in Python 3. For those depending on it, that's
+python3-sgmllib3k: somewhat unfortunate. This is a quick and dirty port of this old
+python3-sgmllib3k: module.
+python3-sgmllib3k:
+python3-sgmllib3k:
+python3-sgmllib3k:
+python3-sgmllib3k:
+python3-sgmllib3k:
+python3-sgmllib3k: