summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2021-01-31 09:39:47 +0100
committer Matteo Bernardini2021-02-27 11:11:02 +0100
commitf7a9be7540d2a7e1466b6e048d29facd3ac78405 (patch)
treecda35f5f39d3c1b54f4e71dd719721e846abbc70
parent9aa1498acb0841d4ce656319a4de5cc157b4e2ed (diff)
downloadslackbuilds-vlc.tar.gz
multimedia/vlc: Enable libva, disable opencv, cleanups.vlc
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--multimedia/vlc/README9
-rw-r--r--multimedia/vlc/vlc.SlackBuild12
2 files changed, 13 insertions, 8 deletions
diff --git a/multimedia/vlc/README b/multimedia/vlc/README
index 48a30411a4..1272ad3c7e 100644
--- a/multimedia/vlc/README
+++ b/multimedia/vlc/README
@@ -37,6 +37,11 @@ environment variable set e.g.
Playing of AV1 encoded video is supported when either of SBo's
multimedia/aom or libraries/dav1d packages is detected when vlc is built.
One of these is expected to become required in a future release.
+Some versions of the automatically detected optional aom package are
+incompatible with this version of vlc and in this case the build will
+fai. This can be avoided by setting the AOM environment variable to "no"
+e.g.
+ AOM=no sh vlc.SlackBuild
Please advise the maintainer to suggest support for any further options.
@@ -44,7 +49,3 @@ Please advise the maintainer to suggest support for any further options.
*NOTES*
- the qt4 interface seems not to be working ATM so the qt5 one is
enabled by default: this means qt5 is a new mandatory dependency
-- you *need* to version-bump the libva and libva-intel-driver in
- Slackware to versions 1.7.3 for VAAPI support: as we suppose
- a standard install, "--enable-libva=no" is added between the
- configure options, instead
diff --git a/multimedia/vlc/vlc.SlackBuild b/multimedia/vlc/vlc.SlackBuild
index 8b8543a820..c024322aca 100644
--- a/multimedia/vlc/vlc.SlackBuild
+++ b/multimedia/vlc/vlc.SlackBuild
@@ -81,6 +81,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
+sed -i '/DEPRECATED/s:^://:' modules/text_renderer/freetype/text_layout.c
+
patch -p0 < $CWD/patch-dvdread-503.diff
patch -p0 < $CWD/patch-dvdnav-503.diff
patch -p0 < $CWD/patch-projectM-fontpath.diff
@@ -105,6 +107,9 @@ fi
# Enable vlc to be run as root
runasroot=""; [ "${RUNASROOT:-no}" != "no" ] && runasroot="--enable-run-as-root"
+# Give the possibility to explicitly disable aom support
+aom=""; [ "${AOM:-yes}" = "no" ] && aom="--disable-aom"
+
autoreconf -fiv
chown -R root:root .
@@ -127,10 +132,10 @@ LDFLAGS="$SLKLDFLAGS" \
--build=$ARCH-slackware-linux \
$qtversion \
$wayland \
- $opencv \
$runasroot \
+ $aom \
+ --disable-opencv \
--enable-merge-ffmpeg \
- --enable-libva=no \
--with-kde-solid=no \
make
@@ -139,8 +144,7 @@ make DESTDIR=$PKG install
mkdir -p $PKG/usr/man/man1
gzip -9c doc/vlc.1 > $PKG/usr/man/man1/vlc.1.gz
-mkdir -p $PKG/$(cd /usr/share/vim/vim*/syntax ; pwd)
-cp extras/analyser/vlc.vim $PKG/$(cd /usr/share/vim/vim*/syntax ; pwd)/
+install -D -m0644 extras/analyser/vlc.vim $PKG/usr/share/vim/vimfiles/syntax/vlc.vim
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION