summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-12-06 16:02:22 +0100
committer Willy Sudiarto Raharjo2019-12-07 17:19:24 +0100
commite79dc4c82d8c163f3be72c0f21e50ae8eb0aa545 (patch)
tree49686326b5cbf1d0b533066a3cbccece4e9ef95b
parentd3dca68bc1fd43d9a23ec2fafc34fb3afdbcfc96 (diff)
downloadslackbuilds-e79dc4c82d8c163f3be72c0f21e50ae8eb0aa545.tar.gz
network/httpie: Added python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--network/httpie/httpie.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/network/httpie/httpie.SlackBuild b/network/httpie/httpie.SlackBuild
index e3c4a04e65..78e0b1011a 100644
--- a/network/httpie/httpie.SlackBuild
+++ b/network/httpie/httpie.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=httpie
VERSION=${VERSION:-1.0.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true