summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-12-06 20:51:40 +0100
committer Willy Sudiarto Raharjo2019-12-07 17:19:24 +0100
commit4e352f3ab60230311eee2970ec8702bc29c5bc35 (patch)
treee05cb301e1c58f77524d83abddfadc7b7c0bf67a
parentf8c841c6bd40fc444fc4d209e71135f75feadf4b (diff)
downloadslackbuilds-4e352f3ab60230311eee2970ec8702bc29c5bc35.tar.gz
python/argh: Added python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/argh/argh.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/argh/argh.SlackBuild b/python/argh/argh.SlackBuild
index 5d357ccb3f..1d74ff4369 100644
--- a/python/argh/argh.SlackBuild
+++ b/python/argh/argh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for argh
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=argh
VERSION=${VERSION:-0.26.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true