summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author William PC2022-10-01 02:45:57 +0200
committer Willy Sudiarto Raharjo2022-10-01 02:45:57 +0200
commitb6641949272d8e024b733ac1733329a5d0cbc319 (patch)
tree76946630038368b342796673ce61a14db6a48c70
parent91aa49367d09b9debc25e8a9b7ca943ca1a985fd (diff)
downloadslackbuilds-b6641949272d8e024b733ac1733329a5d0cbc319.tar.gz
python/python3-fypp: Added (Python powered Fortran metaprogramming).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-fypp/README9
-rw-r--r--python/python3-fypp/python3-fypp.SlackBuild99
-rw-r--r--python/python3-fypp/python3-fypp.info10
-rw-r--r--python/python3-fypp/slack-desc19
4 files changed, 137 insertions, 0 deletions
diff --git a/python/python3-fypp/README b/python/python3-fypp/README
new file mode 100644
index 0000000000..ad081d8ca5
--- /dev/null
+++ b/python/python3-fypp/README
@@ -0,0 +1,9 @@
+ Fypp is a Python powered preprocessor. It can be used for any
+programming languages but its primary aim is to offer a Fortran
+preprocessor, which helps to extend Fortran with condititional
+compiling and template metaprogramming capabilities. Instead of
+introducing its own expression syntax, it uses Python expressions
+in its preprocessor directives, offering the consistency and
+versatility of Python when formulating metaprogramming tasks.
+ It puts strong emphasis on robustness and on neat integration
+into developing toolchains.
diff --git a/python/python3-fypp/python3-fypp.SlackBuild b/python/python3-fypp/python3-fypp.SlackBuild
new file mode 100644
index 0000000000..3fcdf5291a
--- /dev/null
+++ b/python/python3-fypp/python3-fypp.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/bash
+
+# Slackware build script for python3-fypp
+
+# Copyright 2022 William PC (Slack-it) - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-fypp
+SRCNAM=fypp
+VERSION=${VERSION:-3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+# Strip binaries and libraries.
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.rst LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-fypp/python3-fypp.info b/python/python3-fypp/python3-fypp.info
new file mode 100644
index 0000000000..08c828d588
--- /dev/null
+++ b/python/python3-fypp/python3-fypp.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-fypp"
+VERSION="3.1"
+HOMEPAGE="https://github.com/aradi/fypp"
+DOWNLOAD="https://github.com/aradi/fypp/archive/3.1/fypp-3.1.tar.gz"
+MD5SUM="a18dd449deb141b29b8c983d0984906a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/python/python3-fypp/slack-desc b/python/python3-fypp/slack-desc
new file mode 100644
index 0000000000..da7ba7a949
--- /dev/null
+++ b/python/python3-fypp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-fypp: python3-fypp (Python powered Fortran metaprogramming)
+python3-fypp:
+python3-fypp: Fypp is a Python powered preprocessor. It can be used for any
+python3-fypp: programming languages but its primary aim is to offer a Fortran
+python3-fypp: preprocessor, which helps to extend Fortran with condititional
+python3-fypp: compiling and template metaprogramming capabilities. Instead of
+python3-fypp: introducing its own expression syntax, it uses Python expressions
+python3-fypp: in its preprocessor directives, offering the consistency and
+python3-fypp: versatility of Python when formulating metaprogramming tasks.
+python3-fypp: It puts strong emphasis on robustness and on neat integration
+python3-fypp: into developing toolchains.