summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2020-02-01 11:08:52 +0100
committer Matteo Bernardini2021-02-20 20:28:20 +0100
commita9f229f3985a81e4dcd78dd26b5d5319d6313282 (patch)
treec757a742113dd481209b86ade52f13277f4f3975
parent77c0b44bbfd192ed8977df6dcfe55d5defeab350 (diff)
downloadslackbuilds-six.tar.gz
python/six: Removed (added to Slackware).six
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/six/README6
-rw-r--r--python/six/six.SlackBuild83
-rw-r--r--python/six/six.info10
-rw-r--r--python/six/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/six/README b/python/six/README
deleted file mode 100644
index e995a974e8..0000000000
--- a/python/six/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Six is a Python 2 and 3 compatibility library. It provides utility functions for
-smoothing over the differences between the Python versions with the goal of
-writing Python code that is compatible on both Python versions. See the
-documentation for more information on what is provided.
-
-Optional dependencies: Sphinx
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
deleted file mode 100644
index 3c9e04a331..0000000000
--- a/python/six/six.SlackBuild
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for six
-
-# Copyright 2012-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=six
-VERSION=${VERSION:-1.14.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Build and install documentation if sphinx is installed.
-if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
- make -j1 -C documentation man singlehtml
- install -D -m 0644 documentation/_build/man/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
- gzip -9 $PKG/usr/man/man?/*.?
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-[ -d documentation/_build/singlehtml ] && \
- cp -a documentation/_build/singlehtml/index.html \
- documentation/_build/singlehtml/_static \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 '{}' \;
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/six/six.info b/python/six/six.info
deleted file mode 100644
index 700d532f92..0000000000
--- a/python/six/six.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="six"
-VERSION="1.14.0"
-HOMEPAGE="https://pypi.python.org/pypi/six/"
-DOWNLOAD="https://pypi.io/packages/source/s/six/six-1.14.0.tar.gz"
-MD5SUM="21674588a57e649d1a6d977ec3122140"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/six/slack-desc b/python/six/slack-desc
deleted file mode 100644
index 678f603af3..0000000000
--- a/python/six/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-six: six (Python 2 and 3 compatibility utilities)
-six:
-six: Six is a Python 2 and 3 compatibility library. It provides utility
-six: functions for smoothing over the differences between the Python
-six: versions with the goal of writing Python code that is compatible on
-six: both Python versions. See the documentation for more information on
-six: what is provided.
-six:
-six: Homepage: https://pypi.python.org/pypi/six/
-six:
-six: