summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Author: Alexander Verbovetsky2022-06-25 03:40:16 +0200
committer Willy Sudiarto Raharjo2022-07-02 04:55:32 +0200
commit9d66d47f8f5f6cecf1f34dd69e90fef287f56975 (patch)
tree0d269572c11448846cc45cc4d0516108c157d5fb
parentbf8422815729050d9409a1ae020d51acb477dff6 (diff)
downloadslackbuilds-9d66d47f8f5f6cecf1f34dd69e90fef287f56975.tar.gz
python/python3-gmpy2: Removed. Renamed to python-gmpy2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-gmpy2/README8
-rw-r--r--python/python3-gmpy2/python3-gmpy2.SlackBuild85
-rw-r--r--python/python3-gmpy2/python3-gmpy2.info10
-rw-r--r--python/python3-gmpy2/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/python/python3-gmpy2/README b/python/python3-gmpy2/README
deleted file mode 100644
index 7ed7c73b52..0000000000
--- a/python/python3-gmpy2/README
+++ /dev/null
@@ -1,8 +0,0 @@
-gmpy2 is an optimized, c-coded python extension module that supports
-fast multiple-precision arithmetic. gmpy2 is based on the original gmpy
-module. In addition to supporting gmp or mpir for multiple-precision
-integer and rational arithmetic, gmpy2 adds support for the mpfr
-(correctly rounded real floating-point arithmetic) and mpc (correctly
-rounded complex floating-point arithmetic) libraries.
-
-This is the python3 version of gmpy2.
diff --git a/python/python3-gmpy2/python3-gmpy2.SlackBuild b/python/python3-gmpy2/python3-gmpy2.SlackBuild
deleted file mode 100644
index d4dcd6862c..0000000000
--- a/python/python3-gmpy2/python3-gmpy2.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-gmpy2
-
-# Copyright 2019, Alexander Verbovetsky, Moscow, Russia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-gmpy2
-SRCNAM=gmpy2
-VERSION=${VERSION:-2.1.0rc1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xf $CWD/$SRCNAM-$VERSION.tar.?z
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Symbols from the math library are also used
-sed -i "s/'mpfr','gmp'/&,'m'/" setup.py
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README docs $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-gmpy2/python3-gmpy2.info b/python/python3-gmpy2/python3-gmpy2.info
deleted file mode 100644
index c5c64d82c1..0000000000
--- a/python/python3-gmpy2/python3-gmpy2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-gmpy2"
-VERSION="2.1.0rc1"
-HOMEPAGE="https://github.com/aleaxit/gmpy"
-DOWNLOAD="https://files.pythonhosted.org/packages/ea/65/cc97abe9dd0f22d3878a13138ea47d9fc7ff77b0cc16447a35ee777494e1/gmpy2-2.1.0rc1.tar.gz"
-MD5SUM="a1555e0d7ca28b3a49c9a81aa06e2bb6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Alexander Verbovetsky"
-EMAIL="alik@ejik.org"
diff --git a/python/python3-gmpy2/slack-desc b/python/python3-gmpy2/slack-desc
deleted file mode 100644
index cf5f28e8e3..0000000000
--- a/python/python3-gmpy2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-gmpy2: python3-gmpy2 (multi-precision arithmetic for python 3)
-python3-gmpy2:
-python3-gmpy2: gmpy2 is an optimized, c-coded python extension module that supports
-python3-gmpy2: fast multiple-precision arithmetic. gmpy2 is based on the original
-python3-gmpy2: gmpy module. In addition to supporting gmp or mpir for
-python3-gmpy2: multiple-precision integer and rational arithmetic, gmpy2 adds support
-python3-gmpy2: for the mpfr (correctly rounded real floating-point arithmetic) and
-python3-gmpy2: mpc (correctly rounded complex floating-point arithmetic) libraries.
-python3-gmpy2:
-python3-gmpy2: Homepage: https://github.com/aleaxit/gmpy
-python3-gmpy2: