summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:40 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:09 +0200
commit576e459bcd9865a5ea22950c2f9f7599880557cd (patch)
treea926a04e7a26a6abb6670ab95df9e9f769d21b62
parenta38020a4ee371629bddb467176a96a874d22b178 (diff)
downloadslackbuilds-576e459bcd9865a5ea22950c2f9f7599880557cd.tar.gz
gis/python3-cartopy: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--gis/python3-cartopy/python3-cartopy.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/gis/python3-cartopy/python3-cartopy.SlackBuild b/gis/python3-cartopy/python3-cartopy.SlackBuild
index 54e9139051..42993d5796 100644
--- a/gis/python3-cartopy/python3-cartopy.SlackBuild
+++ b/gis/python3-cartopy/python3-cartopy.SlackBuild
@@ -86,7 +86,8 @@ find -L . \
# build line but this is not deemed optimal.
sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl