summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-04-04 06:43:14 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:20 +0200
commit34bd13ef51c0f415f2ff7c4c13783250c5777958 (patch)
treecfaff976338523ae72aaf9f8212ec8c94767dc43
parent25eeabe5ecb7bcd5b8231989204a111ded8ba4ff (diff)
downloadslackbuilds-34bd13ef51c0f415f2ff7c4c13783250c5777958.tar.gz
academic/python3-scipy: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--academic/python3-scipy/python3-scipy.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/academic/python3-scipy/python3-scipy.SlackBuild b/academic/python3-scipy/python3-scipy.SlackBuild
index a3039e8d4c..7586beabdc 100644
--- a/academic/python3-scipy/python3-scipy.SlackBuild
+++ b/academic/python3-scipy/python3-scipy.SlackBuild
@@ -78,7 +78,8 @@ sed -i 's|numpy==1.23.2|numpy>=1.23.2|' pyproject.toml
sed -i 's|pythran>=0.15.0,<0.16.0|pythran|' pyproject.toml
# needs newer meson
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --wheel --no-isolation
python3 -m installer --destdir "$PKG" dist/*.whl