summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2023-12-16 09:00:33 +0100
committer Matteo Bernardini2024-04-20 17:29:21 +0200
commit59bbb0de05e3edc47335fea1cb0b13055598508e (patch)
tree69135cbd7aaf813199a1d64b1b7a6ec1a16380a8
parent7348664936073e3ad54706addd43560c23807ed8 (diff)
downloadslackbuilds-python3-babel.tar.gz
python/python3-babel: Removed (added to Slackware).python3-babel
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python3-babel/README10
-rw-r--r--python/python3-babel/python3-babel.SlackBuild89
-rw-r--r--python/python3-babel/python3-babel.info12
-rw-r--r--python/python3-babel/slack-desc19
4 files changed, 0 insertions, 130 deletions
diff --git a/python/python3-babel/README b/python/python3-babel/README
deleted file mode 100644
index 292ad0fb52..0000000000
--- a/python/python3-babel/README
+++ /dev/null
@@ -1,10 +0,0 @@
-babel (python internationalization tools)
-
-Babel is a collection of tools for internationalizing Python apps.
-It's composed of two major parts:
-- tools to build and work with gettext message catalogs;
-- a Python interface to the CLDR (Common Locale Data Repository),
- providing access to various locale display names, localized number
- and date formatting, etc.
-
-The pytz dependency must be built with optional Python 3 support.
diff --git a/python/python3-babel/python3-babel.SlackBuild b/python/python3-babel/python3-babel.SlackBuild
deleted file mode 100644
index bc8f3ad9e8..0000000000
--- a/python/python3-babel/python3-babel.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-babel
-#
-# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
-# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2013-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-babel
-VERSION=${VERSION:-2.14.0}
-CLDRVER=${CLDRVER:-43.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=babel
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-sed -i "s/getiterator/iter/" scripts/import_cldr.py # support Python 3.9
-sed -i "s/elem.getchildren()/list(elem)/" scripts/import_cldr.py # support Python 3.9
-ln -s $CWD/cldr-common-$CLDRVER.zip cldr/
-python3 setup.py import_cldr
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS* CHANGES* CONTRIBUTING* LICENSE* README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-babel/python3-babel.info b/python/python3-babel/python3-babel.info
deleted file mode 100644
index 9e5f31f41a..0000000000
--- a/python/python3-babel/python3-babel.info
+++ /dev/null
@@ -1,12 +0,0 @@
-PRGNAM="python3-babel"
-VERSION="2.14.0"
-HOMEPAGE="http://babel.pocoo.org/"
-DOWNLOAD="https://github.com/python-babel/babel/archive/v2.14.0/babel-2.14.0.tar.gz \
- http://unicode.org/Public/cldr/43/cldr-common-43.0.zip"
-MD5SUM="6e152ddfd2fbf4ea9c9c6513d23964c0 \
- 29433ac732f0fe62a98b5ab135479162"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pytz"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/python3-babel/slack-desc b/python/python3-babel/slack-desc
deleted file mode 100644
index 3da4910178..0000000000
--- a/python/python3-babel/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-babel: python3-babel (python internationalization tools)
-python3-babel:
-python3-babel: Babel is a collection of tools for internationalizing Python apps.
-python3-babel: It's composed of two major parts:
-python3-babel: - tools to build and work with gettext message catalogs;
-python3-babel: - a Python interface to the CLDR (Common Locale Data Repository),
-python3-babel: providing access to various locale display names, localized number
-python3-babel: and date formatting, etc.
-python3-babel:
-python3-babel: homepage: http://babel.edgewall.org/
-python3-babel: