summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2023-07-15 14:57:29 +0200
committer Matteo Bernardini2024-04-05 22:43:07 +0200
commit3587a8732d77c6fbd295ca332a4fcd72bdd4d4c7 (patch)
tree4dfc48e8adfd8081be170e41bf806ec52d0a64b5
parentca3cfecb6f0115a65c4c9ecc03fa1f7aa1c840a3 (diff)
downloadslackbuilds-ppsspp.tar.gz
games/ppsspp: Use the internal ffmpeg.ppsspp
Upstream supports only that! Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--games/ppsspp/ppsspp.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/ppsspp/ppsspp.SlackBuild b/games/ppsspp/ppsspp.SlackBuild
index cda92afb6c..7282983268 100644
--- a/games/ppsspp/ppsspp.SlackBuild
+++ b/games/ppsspp/ppsspp.SlackBuild
@@ -87,6 +87,10 @@ sed -i -e '/include(ccache)/d' CMakeLists.txt
# set git-version
sed -i "s/unknown/${VERSION}/" git-version.cmake
+# Build the internal ffmpeg (it's the only one supported by upstream)
+( cd ffmpeg
+ ./linux_x86-64.sh )
+
if [ "${QT:-OFF}" = "ON" ]; then
cmake -B build-qt \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
@@ -95,7 +99,6 @@ if [ "${QT:-OFF}" = "ON" ]; then
-DCMAKE_SKIP_RPATH=TRUE \
-DUSING_QT_UI=ON \
-DUSE_SYSTEM_LIBZIP=ON \
- -DUSE_SYSTEM_FFMPEG=ON \
-DUSE_DISCORD=OFF \
-DUSE_SYSTEM_ZSTD=ON \
-DCMAKE_BUILD_TYPE=Release
@@ -111,7 +114,6 @@ cmake -B build-sdl \
-DCMAKE_SKIP_RPATH=TRUE \
-DUSING_QT_UI=OFF \
-DUSE_SYSTEM_LIBZIP=ON \
- -DUSE_SYSTEM_FFMPEG=ON \
-DUSE_DISCORD=OFF \
-DUSE_SYSTEM_ZSTD=ON \
-DCMAKE_BUILD_TYPE=Release