summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2024-05-02 07:07:14 +0200
committer Willy Sudiarto Raharjo2024-05-04 16:45:11 +0200
commit3ad1fe05cc39d6bbf83ff87965d8d21600c05aac (patch)
tree794049b27d73621246cb3fb0605bbdb8f51fc759
parent8103bd006668859595efe85acc3145aecfdd6e90 (diff)
downloadslackbuilds-3ad1fe05cc39d6bbf83ff87965d8d21600c05aac.tar.gz
python/python2-pluggy: Added (python2 version of pluggy).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-pluggy/README6
-rw-r--r--python/python2-pluggy/python2-pluggy.SlackBuild81
-rw-r--r--python/python2-pluggy/python2-pluggy.info10
-rw-r--r--python/python2-pluggy/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python2-pluggy/README b/python/python2-pluggy/README
new file mode 100644
index 0000000000..588eb17442
--- /dev/null
+++ b/python/python2-pluggy/README
@@ -0,0 +1,6 @@
+pluggy (mechanisms for python)
+
+This is the plugin manager as used by pytest but stripped of pytest
+specific details.
+
+This is the Python 2 build of pluggy.
diff --git a/python/python2-pluggy/python2-pluggy.SlackBuild b/python/python2-pluggy/python2-pluggy.SlackBuild
new file mode 100644
index 0000000000..ef6b2874e7
--- /dev/null
+++ b/python/python2-pluggy/python2-pluggy.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/bash
+
+# Slackware build script for pluggy
+
+# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-pluggy
+VERSION=${VERSION:-0.13.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=pluggy
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pluggy/python2-pluggy.info b/python/python2-pluggy/python2-pluggy.info
new file mode 100644
index 0000000000..22082499a2
--- /dev/null
+++ b/python/python2-pluggy/python2-pluggy.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-pluggy"
+VERSION="0.13.1"
+HOMEPAGE="https://github.com/pytest-dev/pluggy"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pluggy/pluggy-0.13.1.tar.gz"
+MD5SUM="7f610e28b8b34487336b585a3dfb803d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python2-setuptools-scm"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"
diff --git a/python/python2-pluggy/slack-desc b/python/python2-pluggy/slack-desc
new file mode 100644
index 0000000000..4d8890c877
--- /dev/null
+++ b/python/python2-pluggy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pluggy: python2-pluggy (mechanisms for python)
+python2-pluggy:
+python2-pluggy: This is the plugin manager as used by pytest but stripped of pytest
+python2-pluggy: specific details.
+python2-pluggy:
+python2-pluggy: Homepage: https://github.com/pytest-dev/pluggy
+python2-pluggy:
+python2-pluggy:
+python2-pluggy:
+python2-pluggy:
+python2-pluggy: