summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2019-12-02 19:52:34 +0100
committer Willy Sudiarto Raharjo2019-12-15 11:06:25 +0100
commit3b993050d3ac49c60961364b8df3d250e6a77e9d (patch)
treeb5a892589df479c7a2bc7f057071dde0eeb58d5f
parent9316c77f83e57b4c69a314637d19902f7f6a4b95 (diff)
downloadslackbuilds-3b993050d3ac49c60961364b8df3d250e6a77e9d.tar.gz
audio/qm-vamp-plugins: Updated for version 1.7.1.
Signed-off-by: B. Watson <yalhcru@gmail.com>
-rw-r--r--audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild28
-rw-r--r--audio/qm-vamp-plugins/qm-vamp-plugins.info10
2 files changed, 17 insertions, 21 deletions
diff --git a/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild b/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild
index 9654efac01..d411e16836 100644
--- a/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild
+++ b/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild
@@ -6,12 +6,13 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20191202 bkw: update for v1.7.1
# 20150403 bkw:
# Bump BUILD to 3, make it build against vamp-plugin-sdk 2.5 (whoops)
PRGNAM=qm-vamp-plugins
-VERSION=${VERSION:-1.7}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-1.7.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -68,17 +69,14 @@ LIBNAM=qm-dsp
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION $LIBNAM-$VERSION
+rm -rf $PRGNAM-$VERSION $LIBNAM-$VERSION $LIBNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
tar xvf $CWD/$LIBNAM-$VERSION.tar.gz
cd $LIBNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# Why doesn't the include path include the project's own include/ dir?
# (without this, it can't find its own headers)
@@ -131,17 +129,17 @@ ln -s $LIBNAM-$VERSION $LIBNAM
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# 20150403 bkw: crap. getting rid of vamp-plugin-sdk static libs
# breaks this. Fix by getting rid of -Wl,-Bstatic and -Wl,-Bdynamic
# options (so it doesn't insisnt on a static libvamp-sdk).
sed -i 's/-Wl,-B[^ ]* //g' build/linux/Makefile.linux64
+# 20191202 bkw: this used to be there, have to re-add it:
+sed -i "/^LDFLAGS/s,\$, -L$TMP/qm-dsp," build/linux/Makefile.linux64
+
fix_sse_flags build/linux/Makefile.linux64
make -f build/linux/Makefile.linux64
@@ -150,9 +148,7 @@ mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/vamp
cp $PRGNAM.so $PRGNAM.cat $PRGNAM.n3 $PKG/usr/lib$LIBDIRSUFFIX/vamp
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README.txt COPYING \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/audio/qm-vamp-plugins/qm-vamp-plugins.info b/audio/qm-vamp-plugins/qm-vamp-plugins.info
index 44db0f531e..f07dbc1dfe 100644
--- a/audio/qm-vamp-plugins/qm-vamp-plugins.info
+++ b/audio/qm-vamp-plugins/qm-vamp-plugins.info
@@ -1,10 +1,10 @@
PRGNAM="qm-vamp-plugins"
-VERSION="1.7"
+VERSION="1.7.1"
HOMEPAGE="http://isophonics.net/QMVampPlugins"
-DOWNLOAD="http://code.soundsoftware.ac.uk/attachments/download/109/qm-vamp-plugins-1.7.tar.gz \
- http://code.soundsoftware.ac.uk/attachments/download/103/qm-dsp-1.7.tar.gz"
-MD5SUM="9340d0e08d72ae712a2fb9da9f6499c5 \
- d167a1477ab40cc3df965ed338dcd6a5"
+DOWNLOAD="https://code.soundsoftware.ac.uk/attachments/download/1604/qm-vamp-plugins-1.7.1.tar.gz \
+ https://code.soundsoftware.ac.uk/attachments/download/1582/qm-dsp-1.7.1.tar.gz"
+MD5SUM="6274bc8bff6f2363404a9f945613bf51 \
+ 9c7a7b15926000e15a9e3c7c06492e58"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="atlas vamp-plugin-sdk"