summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2022-09-19 09:52:08 +0200
committer Matteo Bernardini2024-03-23 09:26:03 +0100
commit4cb41fbeae172914163802a9febfeb5d0ad6f850 (patch)
treeb83be5ae1d5cfee65284804f42048fcd31ac551e
parentecfbf772e938e6dfdc25bbce4ec902ad04952af9 (diff)
downloadslackbuilds-luminance-hdr.tar.gz
graphics/luminance-hdr: Updated for version 2.6.1.1.luminance-hdr
Apply patches from gentoo (thanks to marav for the heads-up!) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--graphics/luminance-hdr/luminance-hdr.SlackBuild5
-rw-r--r--graphics/luminance-hdr/luminance-hdr.info6
-rw-r--r--graphics/luminance-hdr/patches/luminance-hdr-2.5.1-openmp-automagic.patch32
-rw-r--r--graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch22
-rw-r--r--graphics/luminance-hdr/patches/luminance-hdr-2.6.0-docs.patch15
-rw-r--r--graphics/luminance-hdr/patches/luminance-hdr-2.6.0-no-git.patch15
-rw-r--r--graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-fixheaders.patch15
-rw-r--r--graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-openexr3.patch28
8 files changed, 134 insertions, 4 deletions
diff --git a/graphics/luminance-hdr/luminance-hdr.SlackBuild b/graphics/luminance-hdr/luminance-hdr.SlackBuild
index 027d2b07ea..a9bc215aa3 100644
--- a/graphics/luminance-hdr/luminance-hdr.SlackBuild
+++ b/graphics/luminance-hdr/luminance-hdr.SlackBuild
@@ -30,7 +30,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=luminance-hdr
-VERSION=${VERSION:-2.6.0}
+VERSION=${VERSION:-2.6.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,6 +80,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+# Apply patches from gentoo
+for i in $CWD/patches/* ; do patch -p1 < $i ; done
+
# Workround build failure with gcc-g++-4.9.3 and beyond (mangling bug?)
# (fails to link libmvec: "undefined reference to `_ZGVbN4vv_powf'" etc)
export CXX=clang++
diff --git a/graphics/luminance-hdr/luminance-hdr.info b/graphics/luminance-hdr/luminance-hdr.info
index cc84ef4b63..6151b43135 100644
--- a/graphics/luminance-hdr/luminance-hdr.info
+++ b/graphics/luminance-hdr/luminance-hdr.info
@@ -1,8 +1,8 @@
PRGNAM="luminance-hdr"
-VERSION="2.6.0"
+VERSION="2.6.1.1"
HOMEPAGE="http://qtpfsgui.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/qtpfsgui/2.6.0/luminance-hdr-2.6.0.tar.bz2"
-MD5SUM="9ac2be847d304f0ddc7089b251825c4d"
+DOWNLOAD="http://downloads.sf.net/qtpfsgui/luminance-hdr-2.6.1.1.tar.bz2"
+MD5SUM="c57baf1d3c5d7952f952496f20f86c8f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/graphics/luminance-hdr/patches/luminance-hdr-2.5.1-openmp-automagic.patch b/graphics/luminance-hdr/patches/luminance-hdr-2.5.1-openmp-automagic.patch
new file mode 100644
index 0000000000..f0399d271a
--- /dev/null
+++ b/graphics/luminance-hdr/patches/luminance-hdr-2.5.1-openmp-automagic.patch
@@ -0,0 +1,32 @@
+diff --git a/build_files/Modules/CompilerSettings.cmake b/build_files/Modules/CompilerSettings.cmake
+index f55c130..81e1916 100644
+--- a/build_files/Modules/CompilerSettings.cmake
++++ b/build_files/Modules/CompilerSettings.cmake
+@@ -45,16 +45,19 @@ else()
+ message(WARNING "Your C++ compiler does not support C++11.")
+ endif()
+ #OpenMP Support under Linux, Windows with MSVC & MacOS X with GCC >= 4.3
+-IF(MSVC)
+- FIND_PACKAGE(OpenMP REQUIRED)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
+- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
+-ELSEIF(CMAKE_COMPILER_IS_GNUCC AND UNIX)
+- EXECUTE_PROCESS(COMMAND ${CMAKE_CXX_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
+- IF(GCC_VERSION VERSION_GREATER 4.3 OR GCC_VERSION VERSION_EQUAL 4.3)
+- MESSAGE(STATUS "GCC >= 4.3")
++OPTION(USE_OPENMP "Use openmp threading support." ON)
++IF(USE_OPENMP)
++ IF(MSVC)
+ FIND_PACKAGE(OpenMP REQUIRED)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
++ ELSEIF(CMAKE_COMPILER_IS_GNUCC AND UNIX)
++ EXECUTE_PROCESS(COMMAND ${CMAKE_CXX_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
++ IF(GCC_VERSION VERSION_GREATER 4.3 OR GCC_VERSION VERSION_EQUAL 4.3)
++ MESSAGE(STATUS "GCC >= 4.3")
++ FIND_PACKAGE(OpenMP REQUIRED)
++ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
++ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
++ ENDIF()
+ ENDIF()
+ ENDIF()
diff --git a/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch
new file mode 100644
index 0000000000..5564ebadc9
--- /dev/null
+++ b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-cmake.patch
@@ -0,0 +1,22 @@
+--- a/CMakeLists.txt 2019-06-09 21:18:38.000000000 +0200
++++ b/CMakeLists.txt 2019-09-15 23:53:19.496802424 +0200
+@@ -5,19 +5,6 @@
+ CMAKE_POLICY(SET CMP0053 NEW)
+ PROJECT("Luminance HDR")
+
+-string(TOLOWER ${CMAKE_BUILD_TYPE} LOWERCASE_CMAKE_BUILD_TYPE)
+-if(LOWERCASE_CMAKE_BUILD_TYPE MATCHES "^(debug|release|relwithdebinfo|minsizerel)$")
+- message(STATUS "CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
+-else()
+- message(FATAL_ERROR "Invalid value for CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}\n"
+- "CMAKE_BUILD_TYPE should be one of:\nDebug, Release, RelWithDebInfo, MinSizeRel")
+-endif()
+-
+-if(LOWERCASE_CMAKE_BUILD_TYPE MATCHES "^(release|minsizerel)$")
+- message(STATUS "Adding definitions: -DQT_NO_DEBUG_OUTPUT")
+- add_definitions("-DQT_NO_DEBUG_OUTPUT")
+-endif()
+-
+ # assume built-in pthreads on MacOS
+ IF(APPLE)
+ enable_language(CXX)
diff --git a/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-docs.patch b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-docs.patch
new file mode 100644
index 0000000000..982c7ebfac
--- /dev/null
+++ b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-docs.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2019-06-09 21:18:38.000000000 +0200
++++ b/CMakeLists.txt 2019-09-15 23:43:41.005292354 +0200
+@@ -413,12 +413,6 @@
+ INSTALL(FILES ${CMAKE_SOURCE_DIR}/program-icons/luminance-hdr.png DESTINATION share/icons/hicolor/48x48/apps) # icon
+ INSTALL(FILES ${CMAKE_SOURCE_DIR}/net.sourceforge.qtpfsgui.LuminanceHDR.desktop DESTINATION share/applications) #desktop entry
+ INSTALL(FILES ${CMAKE_SOURCE_DIR}/net.sourceforge.qtpfsgui.LuminanceHDR.appdata.xml DESTINATION share/appdata) #appstream
+- INSTALL(FILES
+- ${CMAKE_SOURCE_DIR}/AUTHORS
+- ${CMAKE_SOURCE_DIR}/README.md
+- ${CMAKE_SOURCE_DIR}/LICENSE
+- ${CMAKE_SOURCE_DIR}/Changelog
+- DESTINATION share/luminance-hdr/doc) #info files
+ INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/help DESTINATION share/luminance-hdr) # help directory
+ INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/hdrhtml DESTINATION share/luminance-hdr) # hdrhtml directory
+ # Microsoft Windows
diff --git a/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-no-git.patch b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-no-git.patch
new file mode 100644
index 0000000000..1d95930404
--- /dev/null
+++ b/graphics/luminance-hdr/patches/luminance-hdr-2.6.0-no-git.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2019-06-09 21:18:38.000000000 +0200
++++ b/CMakeLists.txt 2019-09-15 23:41:24.684413834 +0200
+@@ -103,11 +103,7 @@
+ set(LIBS ${LIBS} ${QT_QTWEBKIT_LIBRARIES})
+ endif()
+
+-FIND_PACKAGE(Git)
+-IF(GIT_FOUND)
+- include(GetGitRevisionDescription)
+- get_git_head_revision(GIT_REFSPEC GIT_SHA1)
+-ENDIF()
++SET(GIT_SHA1 "-- Slackware build --")
+
+ IF(WIN32)
+
diff --git a/graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-fixheaders.patch b/graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-fixheaders.patch
new file mode 100644
index 0000000000..58974ea998
--- /dev/null
+++ b/graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-fixheaders.patch
@@ -0,0 +1,15 @@
+Source: arch linux
+
+diff --git a/src/Common/init_fftw.h b/src/Common/init_fftw.h
+index af2fc02c..a4aad47f 100644
+--- a/src/Common/init_fftw.h
++++ b/src/Common/init_fftw.h
+@@ -22,7 +22,7 @@
+ #ifndef INIT_FFTW_H
+ #define INIT_FFTW_H
+
+-#include <boost/thread/mutex.hpp>
++#include <mutex>
+
+ class FFTW_MUTEX {
+ public:
diff --git a/graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-openexr3.patch b/graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-openexr3.patch
new file mode 100644
index 0000000000..9ab2832987
--- /dev/null
+++ b/graphics/luminance-hdr/patches/luminance-hdr-2.6.1.1-openexr3.patch
@@ -0,0 +1,28 @@
+Source: arch linux
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8ff498d0..23f5c387 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -191,7 +191,7 @@ INCLUDE_DIRECTORIES(${TIFF_INCLUDE_DIR})
+ FIND_PACKAGE(PNG REQUIRED)
+ INCLUDE_DIRECTORIES(${PNG_INCLUDE_DIR})
+
+-FIND_PACKAGE(OpenEXR REQUIRED)
++FIND_PACKAGE(OpenEXR CONFIG REQUIRED)
+ INCLUDE_DIRECTORIES(${OPENEXR_INCLUDE_DIR} "${OPENEXR_INCLUDE_DIR}/OpenEXR")
+
+ FIND_PACKAGE(GSL REQUIRED)
+diff --git a/src/Libpfs/CMakeLists.txt b/src/Libpfs/CMakeLists.txt
+index 80617998..ce3c746e 100644
+--- a/src/Libpfs/CMakeLists.txt
++++ b/src/Libpfs/CMakeLists.txt
+@@ -12,7 +12,7 @@ ADD_SUBDIRECTORY(colorspace)
+ ADD_SUBDIRECTORY(io)
+
+ ADD_LIBRARY(pfs STATIC ${LIBPFS_H} ${LIBPFS_HXX} ${LIBPFS_CPP})
+-TARGET_LINK_LIBRARIES(pfs Qt5::Core Qt5::Gui Qt5::Widgets)
++TARGET_LINK_LIBRARIES(pfs Qt5::Core Qt5::Gui Qt5::Widgets OpenEXR::OpenEXR)
+
+ SET(LUMINANCE_MODULES_GUI ${LUMINANCE_MODULES_GUI} pfs PARENT_SCOPE)
+ SET(LUMINANCE_MODULES_CLI ${LUMINANCE_MODULES_CLI} pfs PARENT_SCOPE)