summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Justin Teague2021-02-26 18:22:35 +0100
committer Willy Sudiarto Raharjo2021-02-27 02:24:27 +0100
commit06e1c3f1ed0e1f83e912133a092c4bcf4524be9f (patch)
treefe9fccb413b82fe79c2d52ce9babb9f4596e8ce6
parent2b175505a609cef2e9be5f08ee98023aa7ac7223 (diff)
downloadslackbuilds-06e1c3f1ed0e1f83e912133a092c4bcf4524be9f.tar.gz
desktop/hushboard: Added (Mute your microphone while typing.)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/hushboard/README7
-rw-r--r--desktop/hushboard/doinst.sh9
-rw-r--r--desktop/hushboard/hushboard.SlackBuild93
-rw-r--r--desktop/hushboard/hushboard.desktop12
-rw-r--r--desktop/hushboard/hushboard.info10
-rw-r--r--desktop/hushboard/slack-desc19
6 files changed, 150 insertions, 0 deletions
diff --git a/desktop/hushboard/README b/desktop/hushboard/README
new file mode 100644
index 0000000000..e01fe07a54
--- /dev/null
+++ b/desktop/hushboard/README
@@ -0,0 +1,7 @@
+Never listen to the thundering sounds of someone typing on a video
+call ever again!
+
+Well, nobody who talks to you will have to listen to it. If you
+don’t want to listen to it either, encourage your friends and
+colleagues to install Hushboard. While you’re typing, your mic is
+muted. When you stop, it unmutes again.
diff --git a/desktop/hushboard/doinst.sh b/desktop/hushboard/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/desktop/hushboard/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/hushboard/hushboard.SlackBuild b/desktop/hushboard/hushboard.SlackBuild
new file mode 100644
index 0000000000..8306861f90
--- /dev/null
+++ b/desktop/hushboard/hushboard.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for hushboard
+
+# Copyright 2021 Justin Teague <arcadellama@posteo.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hushboard
+VERSION=${VERSION:-20210221_223b6f9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+COMMIT=${COMMIT:-223b6f97164656bd57bd6c86e9bd297caa37cf85}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py build
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
+cp -a $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+cp -a $PRGNAM-512.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a {LICENSE,README.md} $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/hushboard/hushboard.desktop b/desktop/hushboard/hushboard.desktop
new file mode 100644
index 0000000000..d4d11e5f0f
--- /dev/null
+++ b/desktop/hushboard/hushboard.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Name=Hushboard
+Comment=Mute your microphone while typing
+Comment[en_US]=Mute your microphone while typing
+GenericName=Hushboard
+GenericName[en_US]=Hushboard
+Icon=hushboard
+Exec=hushboard
+Terminal=false
+Keywords=audio;mute;microphone;conference;call;
+Categories=GTK;Utility;
diff --git a/desktop/hushboard/hushboard.info b/desktop/hushboard/hushboard.info
new file mode 100644
index 0000000000..ed5d385957
--- /dev/null
+++ b/desktop/hushboard/hushboard.info
@@ -0,0 +1,10 @@
+PRGNAM="hushboard"
+VERSION="20210221"
+HOMEPAGE="https://kryogenix.org/code/hushboard"
+DOWNLOAD="https://github.com/stuartlangridge/hushboard/archive/223b6f97164656bd57bd6c86e9bd297caa37cf85/hushboard-223b6f97164656bd57bd6c86e9bd297caa37cf85.tar.gz"
+MD5SUM="08578fd3b9907b728ff4d9eb40270d87"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 py3cairo pygobject3-python3 six python-xlib"
+MAINTAINER="Justin Teague"
+EMAIL="arcadellama@posteo.net"
diff --git a/desktop/hushboard/slack-desc b/desktop/hushboard/slack-desc
new file mode 100644
index 0000000000..67a9950937
--- /dev/null
+++ b/desktop/hushboard/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hushboard: hushboard (Mute your microphone while typing.)
+hushboard:
+hushboard: Never listen to the thundering sounds of someone typing on a video
+hushboard: call ever again!
+hushboard:
+hushboard: Well, nobody who talks to you will have to listen to it. If you
+hushboard: don't want to listen to it either, encourage your friends and
+hushboard: colleagues to install Hushboard. While you're typing, your mic is
+hushboard: muted. When you stop, it unmutes again.
+hushboard:
+hushboard: https://kryogenix.org/code/hushboard/