summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Nikos Giotis2020-05-22 15:43:19 +0200
committer Willy Sudiarto Raharjo2020-05-23 04:31:59 +0200
commit28f1f0ab945a27fa257445dd9584c1d1fccd8a8c (patch)
tree918b0fa76a7c7b25deab831fec4cae00cdc4a8b1
parenta3c942f2ca9bcb466b8a312bf64e1b28b0331dc0 (diff)
downloadslackbuilds-28f1f0ab945a27fa257445dd9584c1d1fccd8a8c.tar.gz
python/WTForms: Updated for version 2.3.1.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/WTForms/README6
-rw-r--r--python/WTForms/WTForms.SlackBuild13
-rw-r--r--python/WTForms/WTForms.info6
3 files changed, 16 insertions, 9 deletions
diff --git a/python/WTForms/README b/python/WTForms/README
index 278697b27f..3bba913889 100644
--- a/python/WTForms/README
+++ b/python/WTForms/README
@@ -1,2 +1,4 @@
-WTForms is a flexible forms validation and rendering library for python web
-development.
+WTForms is a flexible forms validation and rendering library for
+python web development.
+
+python3 is autodetected at build time.
diff --git a/python/WTForms/WTForms.SlackBuild b/python/WTForms/WTForms.SlackBuild
index 680886f173..61895c199d 100644
--- a/python/WTForms/WTForms.SlackBuild
+++ b/python/WTForms/WTForms.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for WTForms
-# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
+# Copyright 2017-2020 Nikos Giotis <nikos.giotis@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=WTForms
-VERSION=${VERSION:-2.1}
+VERSION=${VERSION:-2.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -71,11 +71,16 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/WTForms/WTForms.info b/python/WTForms/WTForms.info
index 39a738175c..05d4c90faf 100644
--- a/python/WTForms/WTForms.info
+++ b/python/WTForms/WTForms.info
@@ -1,8 +1,8 @@
PRGNAM="WTForms"
-VERSION="2.1"
+VERSION="2.3.1"
HOMEPAGE="http://wtforms.simplecodes.com/"
-DOWNLOAD="https://pypi.python.org/packages/bf/91/2e553b86c55e9cf2f33265de50e052441fb753af46f5f20477fe9c61280e/WTForms-2.1.zip"
-MD5SUM="6938a541fafd1a1ae2f6b9b88588eef2"
+DOWNLOAD="https://files.pythonhosted.org/packages/68/7a/4ce1636e03a25585f3e1436179232a66c25e53ef17f01b4384d16ace6d61/WTForms-2.3.1.tar.gz"
+MD5SUM="bff06943e59671581af07f80d14bda5f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="babel"