summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2021-03-06 03:27:21 +0100
committer Willy Sudiarto Raharjo2021-03-06 05:11:56 +0100
commitdb545b568565e67693b52a815b65414edf963569 (patch)
tree0b0b9548bf86fbc4c6239da756f4c70945dfcca2
parentadd3675b4665f656ddcecf792a021a39766ab6d5 (diff)
downloadslackbuilds-db545b568565e67693b52a815b65414edf963569.tar.gz
python/python-socks: Added (SOCKS proxy connector for aiohttp)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-socks/README2
-rw-r--r--python/python-socks/python-socks.SlackBuild84
-rw-r--r--python/python-socks/python-socks.info10
-rw-r--r--python/python-socks/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python-socks/README b/python/python-socks/README
new file mode 100644
index 0000000000..a3334d1007
--- /dev/null
+++ b/python/python-socks/README
@@ -0,0 +1,2 @@
+python-socks provides a core proxy client functionality for Python.
+It is used internally by python3-aiohttp-socks.
diff --git a/python/python-socks/python-socks.SlackBuild b/python/python-socks/python-socks.SlackBuild
new file mode 100644
index 0000000000..556c855495
--- /dev/null
+++ b/python/python-socks/python-socks.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for python-socks
+# Copyright 2019-2021 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-socks
+VERSION=${VERSION:-1.2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-socks/python-socks.info b/python/python-socks/python-socks.info
new file mode 100644
index 0000000000..a1e64cf602
--- /dev/null
+++ b/python/python-socks/python-socks.info
@@ -0,0 +1,10 @@
+PRGNAM="python-socks"
+VERSION="1.2.2"
+HOMEPAGE="https://github.com/romis2012/python-socks/"
+DOWNLOAD="https://github.com/romis2012/python-socks/archive/v1.2.2/python-socks-1.2.2.tar.gz"
+MD5SUM="688332177f76f56091f600c8ccc5a067"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python-socks/slack-desc b/python/python-socks/slack-desc
new file mode 100644
index 0000000000..04a47e5569
--- /dev/null
+++ b/python/python-socks/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-socks: python-socks (SOCKS proxy connector for aiohttp)
+python-socks:
+python-socks: python-socks provides a core proxy client functionality for Python.
+python-socks: It is used internally by python3-aiohttp-socks.
+python-socks:
+python-socks:
+python-socks:
+python-socks:
+python-socks:
+python-socks:
+python-socks: