summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-08-13 03:16:09 +0200
committer Willy Sudiarto Raharjo2022-08-13 03:16:09 +0200
commitbeb32a9b4fb88a133c55af1a7874dec07ba85228 (patch)
treea14a0a7f4259844ce1d0567f0817c529d28df3d6
parent4583a89a4c9d1b345f7bafa46d397160d9d9006f (diff)
downloadslackbuilds-beb32a9b4fb88a133c55af1a7874dec07ba85228.tar.gz
python/python3-mpmath: Removed (Replaced by python-mpmath).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-mpmath/README9
-rw-r--r--python/python3-mpmath/python3-mpmath.SlackBuild98
-rw-r--r--python/python3-mpmath/python3-mpmath.info10
-rw-r--r--python/python3-mpmath/slack-desc19
4 files changed, 0 insertions, 136 deletions
diff --git a/python/python3-mpmath/README b/python/python3-mpmath/README
deleted file mode 100644
index 84808f855a..0000000000
--- a/python/python3-mpmath/README
+++ /dev/null
@@ -1,9 +0,0 @@
-mpmath is a free (BSD licensed) Python library for real and complex
-floating-point arithmetic with arbitrary precision. It has been
-developed by Fredrik Johansson since 2007, with help from many
-contributors.
-
-This is the python3 version of mpmath and it can coexist with SBo's
-mpmath package.
-
-python-gmpy2 is an optional runtime dependency.
diff --git a/python/python3-mpmath/python3-mpmath.SlackBuild b/python/python3-mpmath/python3-mpmath.SlackBuild
deleted file mode 100644
index 67e5042080..0000000000
--- a/python/python3-mpmath/python3-mpmath.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-mpmath
-
-# Copyright SlackBuilds.org Project, David Melik, 2015, Spokane, WA, USA
-# Copyright 2019-2022, Alexander Verbovetsky, Moscow, Russia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-mpmath
-SRCNAM=mpmath
-VERSION=${VERSION:-1.2.1}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-find ./ -type f -name '*.py' -exec \
- sed -i -e 's|#!/usr/bin/python\>|#!/usr/bin/python3|' \
- -e 's|#!/usr/bin/env python\>|#!/usr/bin/env python3|' {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE README.rst TODO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-mpmath/python3-mpmath.info b/python/python3-mpmath/python3-mpmath.info
deleted file mode 100644
index 6e3816bbdb..0000000000
--- a/python/python3-mpmath/python3-mpmath.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-mpmath"
-VERSION="1.2.1"
-HOMEPAGE="http://mpmath.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/95/ba/7384cb4db4ed474d4582944053549e02ec25da630810e4a23454bc9fa617/mpmath-1.2.1.tar.gz"
-MD5SUM="ef8a6449851755319673b06f71731d52"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Alexander Verbovetsky"
-EMAIL="alik@ejik.org"
diff --git a/python/python3-mpmath/slack-desc b/python/python3-mpmath/slack-desc
deleted file mode 100644
index 95948c260a..0000000000
--- a/python/python3-mpmath/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-mpmath: python3-mpmath (arithmetic library)
-python3-mpmath:
-python3-mpmath: Mpmath is a free (BSD licensed) Python library for real and complex
-python3-mpmath: floating-point arithmetic with arbitrary precision. It has been
-python3-mpmath: developed by Fredrik Johansson since 2007, with help from many
-python3-mpmath: contributors.
-python3-mpmath:
-python3-mpmath: http://mpmath.org/
-python3-mpmath:
-python3-mpmath:
-python3-mpmath: