summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pouria Rezaei2021-04-02 20:25:46 +0200
committer Willy Sudiarto Raharjo2021-04-03 03:48:32 +0200
commita1c9b24048ed89ce34d52b7ba4c9cbb41f339704 (patch)
tree464fbcf2fe16a6f4c2ef6231aa5b47c822e754f9
parent7935a4b9922c414ce0bdd658713b1c3046cb7604 (diff)
downloadslackbuilds-a1c9b24048ed89ce34d52b7ba4c9cbb41f339704.tar.gz
python/python3-pulsectl: Added (Pulse-control Python3 library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pulsectl/README10
-rw-r--r--python/python3-pulsectl/python3-pulsectl.SlackBuild92
-rw-r--r--python/python3-pulsectl/python3-pulsectl.info10
-rw-r--r--python/python3-pulsectl/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/python/python3-pulsectl/README b/python/python3-pulsectl/README
new file mode 100644
index 0000000000..bef884264c
--- /dev/null
+++ b/python/python3-pulsectl/README
@@ -0,0 +1,10 @@
+Python (3.x and 2.x) blocking high-level interface and ctypes-based
+bindings for PulseAudio (libpulse), to use in a simple synchronous code.
+Wrappers are mostly for mixer-like controls and introspection-related
+operations, as opposed to e.g. submitting sound samples to play and
+player-like client.
+For async version to use with asyncio, see pulsectl-asyncio project
+instead.
+Originally forked from pulsemixer project, which had this code bundled.
+
+By ~red
diff --git a/python/python3-pulsectl/python3-pulsectl.SlackBuild b/python/python3-pulsectl/python3-pulsectl.SlackBuild
new file mode 100644
index 0000000000..965accab09
--- /dev/null
+++ b/python/python3-pulsectl/python3-pulsectl.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python3-pulsectl
+
+# Copyright 2019-2020 Pouria Rezaei <Pouria.rz@outlook.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=python3-pulsectl
+SRCNAM=pulsectl
+VERSION=${VERSION:-21.3.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s~.*scripts=glob.glob(\"Scripts/\*.py\"),~~" setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install documentation.
+mkdir -p $PRGDOC
+cat $CWD/README > $PRGDOC/README
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-pulsectl/python3-pulsectl.info b/python/python3-pulsectl/python3-pulsectl.info
new file mode 100644
index 0000000000..9a109b8b06
--- /dev/null
+++ b/python/python3-pulsectl/python3-pulsectl.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pulsectl"
+VERSION="21.3.4"
+HOMEPAGE="https://github.com/mk-fg/python-pulse-control"
+DOWNLOAD="https://files.pythonhosted.org/packages/82/50/9ab6147b657b20c1a7c3b72b285fc94f572c6005735bb0364a40f8b337a1/pulsectl-21.3.4.tar.gz"
+MD5SUM="e74990684ecd70b946bbd18dbfab23cf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Pouria Rezaei"
+EMAIL="Pouria.rz@outlook.com"
diff --git a/python/python3-pulsectl/slack-desc b/python/python3-pulsectl/slack-desc
new file mode 100644
index 0000000000..b5ff616ce5
--- /dev/null
+++ b/python/python3-pulsectl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pulsectl: python3-pulsectl (Pulse-control Python3 library)
+python3-pulsectl:
+python3-pulsectl: Python (3.x and 2.x) blocking high-level interface and
+python3-pulsectl: ctypes-based bindings for PulseAudio (libpulse), to use in a simple
+python3-pulsectl: synchronous code. Wrappers are mostly for mixer-like controls and
+python3-pulsectl: introspection-related operations, as opposed to e.g. submitting
+python3-pulsectl: sound samples to play and player-like client. For async version to
+python3-pulsectl: use with asyncio, see pulsectl-asyncio project instead. Originally
+python3-pulsectl: forked from pulsemixer project, which had this code bundled.
+python3-pulsectl:
+python3-pulsectl: Homepage: https://github.com/mk-fg/python-pulse-control