summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pouria Rezaei2021-04-02 20:13:23 +0200
committer Willy Sudiarto Raharjo2021-04-03 03:48:32 +0200
commit7fa5450a08dbffbc78ad3f9dfa6368b92e8e1b54 (patch)
treec449a8fc872e174f0395bb7f81b0a339576ba7fd
parent5526cf82a84de3c7aee7f638ec6ccbbad3d4ddbb (diff)
downloadslackbuilds-7fa5450a08dbffbc78ad3f9dfa6368b92e8e1b54.tar.gz
python/python3-pysdl2: Added (PySDL2 Python3 library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pysdl2/README10
-rw-r--r--python/python3-pysdl2/python3-pysdl2.SlackBuild92
-rw-r--r--python/python3-pysdl2/python3-pysdl2.info10
-rw-r--r--python/python3-pysdl2/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/python/python3-pysdl2/README b/python/python3-pysdl2/README
new file mode 100644
index 0000000000..793874187b
--- /dev/null
+++ b/python/python3-pysdl2/README
@@ -0,0 +1,10 @@
+PySDL2 is a pure Python wrapper around the SDL2, SDL2_mixer,
+SDL2_image, SDL2_ttf, and SDL2_gfx libraries. Instead of relying on C
+code, it uses the built-in ctypes module to interface with SDL2, and
+provides simple Python classes and wrappers for common SDL2
+functionality.
+
+This package changed the path to python3.x incase of some of my
+packages dependencies and the sake of Python3.
+
+By ~red
diff --git a/python/python3-pysdl2/python3-pysdl2.SlackBuild b/python/python3-pysdl2/python3-pysdl2.SlackBuild
new file mode 100644
index 0000000000..f27f6a998a
--- /dev/null
+++ b/python/python3-pysdl2/python3-pysdl2.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python3-pysdl2
+
+# Copyright 2019-2020 Pouria Rezaei <Pouria.rz@outlook.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=python3-pysdl2
+SRCNAM=PySDL2
+VERSION=${VERSION:-0.9.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s~.*scripts=glob.glob(\"Scripts/\*.py\"),~~" setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install documentation.
+mkdir -p $PRGDOC
+cat $CWD/README > $PRGDOC/README
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-pysdl2/python3-pysdl2.info b/python/python3-pysdl2/python3-pysdl2.info
new file mode 100644
index 0000000000..bfd2d56b44
--- /dev/null
+++ b/python/python3-pysdl2/python3-pysdl2.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pysdl2"
+VERSION="0.9.7"
+HOMEPAGE="https://github.com/marcusva/py-sdl2"
+DOWNLOAD="https://files.pythonhosted.org/packages/39/58/21d31ceba68b7d8c06be5ee620264bc91a5a7c69b796a7c32aae9e8b10bc/PySDL2-0.9.7.tar.gz"
+MD5SUM="e77e9c15589e15b6c877555f34a429ab"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Pouria Rezaei"
+EMAIL="Pouria.rz@outlook.com"
diff --git a/python/python3-pysdl2/slack-desc b/python/python3-pysdl2/slack-desc
new file mode 100644
index 0000000000..37610d4730
--- /dev/null
+++ b/python/python3-pysdl2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pysdl2: python3-pysdl2 (PySDL2 Python3 library)
+python3-pysdl2:
+python3-pysdl2: PySDL2 is a pure Python wrapper around the SDL2, SDL2_mixer,
+python3-pysdl2: SDL2_image, SDL2_ttf, and SDL2_gfx libraries. Instead of relying on
+python3-pysdl2: C code, it uses the built-in ctypes module to interface with SDL2, and
+python3-pysdl2: provides simple Python classes and wrappers for common SDL2
+python3-pysdl2: functionality.
+python3-pysdl2:
+python3-pysdl2:
+python3-pysdl2:
+python3-pysdl2: https://github.com/marcusva/py-sdl2