summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pouria Rezaei2021-04-02 20:22:52 +0200
committer Willy Sudiarto Raharjo2021-04-03 03:48:32 +0200
commit7935a4b9922c414ce0bdd658713b1c3046cb7604 (patch)
tree2febfed016cc775a5c465540f77a1b520846268a
parenta5ecb7174fd191605e67885704bca169e58ce1d5 (diff)
downloadslackbuilds-7935a4b9922c414ce0bdd658713b1c3046cb7604.tar.gz
python/python3-pylyrics: Added (PyLyrics Python3 library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pylyrics/README5
-rw-r--r--python/python3-pylyrics/python3-pylyrics.SlackBuild92
-rw-r--r--python/python3-pylyrics/python3-pylyrics.info10
-rw-r--r--python/python3-pylyrics/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python3-pylyrics/README b/python/python3-pylyrics/README
new file mode 100644
index 0000000000..c10a196852
--- /dev/null
+++ b/python/python3-pylyrics/README
@@ -0,0 +1,5 @@
+PyLyrics is a python module to get Lyrics of songs from
+lyrics.wikia.com. It has support for getting albums of a singer and
+songs from an album from which lyrics can be accessed.
+
+By ~red
diff --git a/python/python3-pylyrics/python3-pylyrics.SlackBuild b/python/python3-pylyrics/python3-pylyrics.SlackBuild
new file mode 100644
index 0000000000..83d377c35c
--- /dev/null
+++ b/python/python3-pylyrics/python3-pylyrics.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python3-pylyrics
+
+# Copyright 2019-2020 Pouria Rezaei <Pouria.rz@outlook.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=python3-pylyrics
+SRCNAM=PyLyrics
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+unzip $CWD/$SRCNAM-$VERSION.zip
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s~.*scripts=glob.glob(\"Scripts/\*.py\"),~~" setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install documentation.
+mkdir -p $PRGDOC
+cat $CWD/README > $PRGDOC/README
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-pylyrics/python3-pylyrics.info b/python/python3-pylyrics/python3-pylyrics.info
new file mode 100644
index 0000000000..10fc210a7b
--- /dev/null
+++ b/python/python3-pylyrics/python3-pylyrics.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pylyrics"
+VERSION="1.1.0"
+HOMEPAGE="https://github.com/geekpradd/PyLyrics"
+DOWNLOAD="https://files.pythonhosted.org/packages/9d/74/8e92322cb1425739849eb719c3b5d8ca05a6b1f027829fd56b4db7c4b7c7/PyLyrics-1.1.0.zip"
+MD5SUM="1f3c997edeba149a8fb2b861cbad89c3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Pouria Rezaei"
+EMAIL="Pouria.rz@outlook.com"
diff --git a/python/python3-pylyrics/slack-desc b/python/python3-pylyrics/slack-desc
new file mode 100644
index 0000000000..2d3dc7ee5c
--- /dev/null
+++ b/python/python3-pylyrics/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pylyrics: python3-pylyrics (PyLyrics Python3 library for Slackware)
+python3-pylyrics:
+python3-pylyrics: PyLyrics is a python module to get Lyrics of songs from
+python3-pylyrics: lyrics.wikia.com.
+python3-pylyrics: It has support for getting albums of a singer and songs from an album
+python3-pylyrics: from which lyrics can be accessed.
+python3-pylyrics:
+python3-pylyrics:
+python3-pylyrics:
+python3-pylyrics:
+python3-pylyrics: Homepage: https://github.com/geekpradd/PyLyrics