summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2020-11-13 09:18:07 +0100
committer Willy Sudiarto Raharjo2020-11-14 11:16:48 +0100
commit9ee8b6bf576d67407f991462c497eabef8e53079 (patch)
treed0e4070889699fdd7f837e46ab113694d93844c8
parent28817f974c587ca5a36f059deb868832f42238fb (diff)
downloadslackbuilds-9ee8b6bf576d67407f991462c497eabef8e53079.tar.gz
network/sic: New maintainer.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/sic/README11
-rw-r--r--network/sic/sic.SlackBuild36
-rw-r--r--network/sic/sic.info4
-rw-r--r--network/sic/slack-desc2
4 files changed, 35 insertions, 18 deletions
diff --git a/network/sic/README b/network/sic/README
index e721f1205d..c4a96694d5 100644
--- a/network/sic/README
+++ b/network/sic/README
@@ -1 +1,10 @@
-sic is an extremely simple IRC client.
+sic (simple irc client)
+
+sic is an extremely simple IRC client. It consists of less than 250
+lines of code.
+
+The default host is "irc.oftc.net" and the default port is 6667. You
+can change these by setting IRCHOST and/or IRCPORT in the script's
+environment, e.g.:
+
+# IRCHOST=chat.freenode.org IRCPORT=6668 ./sic.SlackBuild
diff --git a/network/sic/sic.SlackBuild b/network/sic/sic.SlackBuild
index f46aba1f79..fb4c624018 100644
--- a/network/sic/sic.SlackBuild
+++ b/network/sic/sic.SlackBuild
@@ -1,7 +1,8 @@
#!/bin/sh
#
# Slackware build script for sic
-# Copyright 2011 Haroldo F. Jardim <hfjardim@gmail.com>
+# Copyright 2011 Haroldo F. Jardim <email removed>
+# Now maintained by B. Watson <yalhcru@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,6 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20201113 bkw: The original author of this script hasn't been heard
+# from since 2011, and it needs some attention (still mentions i486)
+# so I'm taking it.
+# - new maintainer
+# - i486 => i586
+# - fix that => than typo in slack-desc
+# - expand README a bit
+# - add env vars for default host and port
+# - simplify script
+
PRGNAM=sic
VERSION=${VERSION:-1.2}
BUILD=${BUILD:-1}
@@ -28,7 +39,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -62,31 +73,28 @@ rm -rf $PRGNAM-$VERSION
tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod 644 *
sed -i "s/CFLAGS =/CFLAGS +=/" config.mk
-CFLAGS="$SLKCFLAGS" \
+[ -n "$IRCHOST" ] && \
+ sed -i "/host *= *\"/s,\"[^\"]*\",\"$IRCHOST\"," $PRGNAM.c
+
+[ -n "$IRCPORT" ] && \
+ sed -i "/port *= *\"/s,\"[^\"]*\",\"$IRCPORT\"," $PRGNAM.c
+
+CFLAGS="$SLKCFLAGS -Wl,-s" \
DESTDIR=$PKG \
make \
PREFIX=/usr \
MANPREFIX=/usr/man \
install
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/network/sic/sic.info b/network/sic/sic.info
index d3b6e83971..f466828855 100644
--- a/network/sic/sic.info
+++ b/network/sic/sic.info
@@ -6,5 +6,5 @@ MD5SUM="eb099e790c3ce7866df50d3fe1a52c25"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Haroldo F. Jardim"
-EMAIL="hfjardim@gmail.com"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/network/sic/slack-desc b/network/sic/slack-desc
index a5f706b903..8a2a71b460 100644
--- a/network/sic/slack-desc
+++ b/network/sic/slack-desc
@@ -8,7 +8,7 @@
|-----handy-ruler------------------------------------------------------|
sic: sic (simple irc client)
sic:
-sic: sic is an extremely simple IRC client. It consists of less that 250
+sic: sic is an extremely simple IRC client. It consists of less than 250
sic: lines of code.
sic:
sic: http://tools.suckless.org/sic