summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky2020-11-07 01:15:55 +0100
committer Willy Sudiarto Raharjo2020-11-07 08:02:27 +0100
commite2b2103860d080ff5cc1f779504081a2c60031e6 (patch)
treec65dd734ccf15de627cdb351a378997557723685
parent373a648772cf8708d9f44ba4b931c09271234814 (diff)
downloadslackbuilds-e2b2103860d080ff5cc1f779504081a2c60031e6.tar.gz
libraries/libbson: Updated for version 1.17.2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/libbson/README3
-rw-r--r--libraries/libbson/libbson.SlackBuild38
-rw-r--r--libraries/libbson/libbson.info8
-rw-r--r--libraries/libbson/slack-desc4
4 files changed, 33 insertions, 20 deletions
diff --git a/libraries/libbson/README b/libraries/libbson/README
index 3c3c7b7dec..151c173687 100644
--- a/libraries/libbson/README
+++ b/libraries/libbson/README
@@ -5,3 +5,6 @@ format of MongoDB. It also converts BSON to and from JSON, and provides
a platform compatibility layer for the MongoDB C Driver.
libbson conflicts with mongo-c-driver.
+
+To build the libbson documentation, install Sphinx and set
+DOCS=yes
diff --git a/libraries/libbson/libbson.SlackBuild b/libraries/libbson/libbson.SlackBuild
index b0f490a6cf..0f824697a9 100644
--- a/libraries/libbson/libbson.SlackBuild
+++ b/libraries/libbson/libbson.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=libbson
SRCNAM=mongo-c-driver
-VERSION=${VERSION:-1.17.0}
+VERSION=${VERSION:-1.17.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,7 +61,6 @@ rm -rf $TMP/$PKGNAM-$VERSION $PKG
mkdir -p $TMP/$PKGNAM-$VERSION $PKG $OUTPUT
cd $TMP/$PKGNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-ar p $CWD/$PRGNAM-doc_${VERSION}-*_all.deb data.tar.xz | tar xvJ
chown -R root:root .
find -L . \
@@ -70,13 +69,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-mkdir -p $PKG/usr/man $PKG/usr/doc/$PRGNAM-$VERSION
-mv usr/share/man/man3 $PKG/usr/man
-mv usr/share/doc/libbson-dev/html $PKG/usr/doc/$PRGNAM-$VERSION
-
-cd $SRCNAM-$VERSION
+PDOCS=""
+MkDOCS=""
+if [ "${DOCS:-no}" = "yes" ]; then
+ PDOCS="-DENABLE_MAN_PAGES=ON -DENABLE_HTML_DOCS=ON"
+ MkDOCS="bson-doc"
+fi
-cd build
+cd $SRCNAM-$VERSION/build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -84,8 +84,9 @@ cd build
-DENABLE_TESTS=OFF \
-DENABLE_AUTOMATIC_INIT_AND_CLEANUP=OFF \
-DENABLE_MONGOC=OFF \
+ $PDOCS \
-DCMAKE_BUILD_TYPE=Release ..
- make
+ make $MkDOCS
make install DESTDIR=$PKG
cd ..
@@ -94,11 +95,22 @@ rm -rf $PKG/usr/share
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
+if [ "${DOCS:-no}" = "yes" ]; then
+ mkdir -p $PKG/usr/man
+ cd src/$PRGNAM/doc
+ rm -f {html,man}/CMakeLists.txt
+ mv man $PKG/usr/man/man3
+ mv html $PKG/usr/doc/$PRGNAM-$VERSION
+ cd ../../..
+
+ find $PKG/usr/man -type f -exec gzip -9 {} \;
+ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+fi
-cd src/$PRGNAM
-cp -a NEWS THIRD_PARTY_NOTICES examples $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a NEWS THIRD_PARTY_NOTICES README.rst CONTRIBUTING.md \
+ src/libbson/examples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/libbson/libbson.info b/libraries/libbson/libbson.info
index 42522312d3..2f192ab826 100644
--- a/libraries/libbson/libbson.info
+++ b/libraries/libbson/libbson.info
@@ -1,10 +1,8 @@
PRGNAM="libbson"
-VERSION="1.17.0"
+VERSION="1.17.2"
HOMEPAGE="https://mongoc.org/libbson/current/index.html"
-DOWNLOAD="https://github.com/mongodb/mongo-c-driver/releases/download/1.17.0/mongo-c-driver-1.17.0.tar.gz \
- https://deb.debian.org/debian/pool/main/m/mongo-c-driver/libbson-doc_1.17.0-1_all.deb"
-MD5SUM="2201cea8f31c6e7a4215e736dd74627a \
- 49820d0101c3734a155234774b56392d"
+DOWNLOAD="https://github.com/mongodb/mongo-c-driver/releases/download/1.17.2/mongo-c-driver-1.17.2.tar.gz"
+MD5SUM="bac783be0c235f232b95307d641b0b89"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/libbson/slack-desc b/libraries/libbson/slack-desc
index 823e133486..291f5fe177 100644
--- a/libraries/libbson/slack-desc
+++ b/libraries/libbson/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
libbson: libbson (a cross platform BSON Library for C)
libbson:
-libbson:
libbson: libbson builds, parses, and iterates BSON documents, the native data
libbson: format of MongoDB. It also converts BSON to and from JSON, and
libbson: provides a platform compatibility layer for the MongoDB C Driver.
libbson:
-libbson:
libbson: Homepage: https://mongoc.org/libbson/current/index.html
libbson:
libbson:
+libbson:
+libbson: