summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2020-11-05 06:43:57 +0100
committer Willy Sudiarto Raharjo2020-11-07 08:02:35 +0100
commit52cdbdbdfe9715db75108a20fd18bd5dcb16caab (patch)
tree8057968388f1321b4c9a6d063cc4581a5333f09f
parent83d0ed59673a1c69f7e1ce8a9baa3095b403ba92 (diff)
downloadslackbuilds-52cdbdbdfe9715db75108a20fd18bd5dcb16caab.tar.gz
development/inform: Updated for version 6.34_6.12.4_1.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/inform/README8
-rw-r--r--development/inform/inform.SlackBuild99
-rw-r--r--development/inform/inform.info6
-rw-r--r--development/inform/parallel_make.diff20
4 files changed, 98 insertions, 35 deletions
diff --git a/development/inform/README b/development/inform/README
index 269cb5a5ac..8eaa8177c2 100644
--- a/development/inform/README
+++ b/development/inform/README
@@ -13,11 +13,11 @@ This is a command-line compiler for the Inform 6 language. For a
graphical Inform 7 compiler, see gnome-inform7. Inform 6 and 7 are
completely different languages, so it's not redundant to install both.
-To get started writing interactive fiction with Inform, everything you
-need is installed in /usr/doc/inform-$VERSION:
+To get started writing interactive fiction with Inform, all the
+documentation you need is installed in /usr/doc/inform-$VERSION:
-inform_beginners_guide.pdf - Read this first.
-manual/index.html - The Designer's Manual. Everything you need to know.
+inform_beginners_guide.pdf - aka IBG. Read this first.
+manual/index.html - Inform Designer's Manual, aka DM4.
tutor/*.inf - Tutorials in Inform source code format.
demos/*.inf - Source to sample games.
diff --git a/development/inform/inform.SlackBuild b/development/inform/inform.SlackBuild
index 7879eddc00..912dc6da68 100644
--- a/development/inform/inform.SlackBuild
+++ b/development/inform/inform.SlackBuild
@@ -6,6 +6,11 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20201104 bkw: updated for 6.34_6.12.4. In case anyone's wondering
+# why I use a self-hosted URL for the source, it's because upstream
+# moves the old source immediately when a new release is made. Also
+# moved the binary to /usr/games and the man page to section 6.
+
# 20191216 bkw: updated for 6.34_6.12.2. The secondary version number
# is the inform6 library version. This script can no longer build the
# old 6.32.1 version, but it should be fine for future releases.
@@ -17,7 +22,7 @@
# demand, I'll dig up the old includes and re-add them to the package.
PRGNAM=inform
-VERSION=${VERSION:-6.34_6.12.2}
+VERSION=${VERSION:-6.34_6.12.4_1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,8 +57,9 @@ set -e
MANVER="${MANVER:-4}"
MANUAL=designers_manual_${MANVER}.zip
-TARVER="${VERSION/_/-}"
-DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
+TARVER="${VERSION//_/-}"
+DOCDIR=/usr/doc/$PRGNAM-$VERSION
+PKGDOC=$PKG/$DOCDIR
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -65,37 +71,74 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Upstream got rid of autotools, which I consider a step in the right
-# direction... but they also got rid of DESTDIR support.
+# 20201104 bkw: Since inform is for game purposes, install the binary
+# to /usr/games, and its man page to section 6.
+sed '1s/"1"/"6"/' $PRGNAM.1 > $PRGNAM.6
-make OPTS="$SLKCFLAGS" \
- PREFIX=/usr \
+# 20201105 bkw: Minor fixes to Makefile so parallel builds work.
+patch -p1 < $CWD/parallel_make.diff
+# 20201104 bkw: Don't write to real $PREFIX! Just disable the CASETEST
+# stuff, since we're including our own set of symlinks.
+sed -i '/touch.*PREFIX/,+2d' Makefile
+
+# 20201104 bkw: upstream now supports DESTDIR again.
make install-strip \
- PREFIX=$PKG/usr \
+ OPTS="$SLKCFLAGS" \
+ BINDIR=/usr/games \
+ MANDIR=/usr/man/man6 \
+ MANPAGE=$PRGNAM.6 \
+ PREFIX=/usr \
TUTORDIR=$DOCDIR/tutor \
- DEMODIR=$DOCDIR/demos
+ DEMODIR=$DOCDIR/demos \
+ DESTDIR=$PKG
+
+gzip $PKG/usr/man/man?/*.?
+
+# 20201104 bkw: the binary got moved, be kind and provide a symlink
+mkdir -p $PKG/usr/bin
+ln -s ../games/$PRGNAM $PKG/usr/bin/$PRGNAM
+
+# Inform started life (and is still used primarily) on OSes
+# with case-insensitive filenames, meaning that a lot of inform
+# source refers to e.g. VerbLib or even VERBLIB (with or without
+# the .h at the end, which could also be capitalized as .H). The
+# Makefile can create a few symlinks to support this, but let's
+# be more all-inclusive. We got 8 .h files, and end up with 70+
+# symlinks. There's no kill like overkill!
+( cd $PKG/usr/share/$PRGNAM/lib
+ for file in *.h; do
+ name=${file%%.*}
+ # Name.h NAME.h
+ for link in ${name^}.h ${name^^}.h; do
+ ln -s $file $link
+ done
+ done
-gzip $PKG/usr/man/man1/*.1
+ # MixedCase isn't standardized, these are guesses. Some are pretty
+ # unlikely, but they don't cost much. Better to have and not need,
+ # than to need and not have.
+ for link in VerbLib VerbLIB verbLib verbLIB \
+ InFix InFIX inFix inFIX \
+ InfGlk InfGLK infGlk infGLK \
+ LinkLpa LinkLPA linkLpa linkLPA
+ do
+ ln -s ${link,,}.h $link.h
+ done
-# Inform started life (and is still used primarily) on OSes with
-# case-insensitive filenames. The library include files are
-# duplicated here, with e.g. 3 identical files called verblib.h,
-# Verblib.h, VerbLib.h. Clean up the mess.
-( cd $PKG/usr/share/$PRGNAM/lib
- for upper in [A-Z]*.h; do
- lower="$( echo $upper | tr A-Z a-z )"
- if [ -e "$lower" ]; then
- rm -f "$upper"
- ln -s "$lower" "$upper"
- fi
+ # Any of the above might appear with .H. Use readlink so all the
+ # variant names link to the real file (no symlinks to symlinks).
+ # This might be overcautious: the example code all just says
+ # e.g. 'Include "Parser"', without the .h.
+ for file in *.h; do
+ ln -s $( readlink $file ) ${file%%.*}.H
done
)
# Upstream removed the manual for licensing reasons. It belongs in the
# binary package IMO.
-mkdir -p $DOCDIR/manual
-( cd $DOCDIR/manual
+mkdir -p $PKGDOC/manual
+( cd $PKGDOC/manual
unzip $CWD/$MANUAL
# manual has no subdirs
chmod 644 *
@@ -103,17 +146,17 @@ mkdir -p $DOCDIR/manual
)
# Inform Beginners' Guide, required reading.
-cat $CWD/IBG.pdf > $DOCDIR/inform_beginners_guide.pdf
+cat $CWD/IBG.pdf > $PKGDOC/inform_beginners_guide.pdf
-mkdir -p $DOCDIR/lib
+mkdir -p $PKGDOC/lib
for i in ChangeLog README.txt voices_and_tenses.txt; do
- ln -s ../../../share/$PRGNAM/lib/$i $DOCDIR/lib
+ ln -s ../../../share/$PRGNAM/lib/$i $PKGDOC/lib
done
# ARTISTIC and COPYING are redundant: src/licence.txt includes the
# full text of both.
-cp -a AUTHORS NEWS README* src/*.txt src/*.html docs/* $DOCDIR
-cat $CWD/$PRGNAM.SlackBuild > $DOCDIR/$PRGNAM.SlackBuild
+cp -a AUTHORS NEWS README* src/*.txt src/*.html docs/* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/development/inform/inform.info b/development/inform/inform.info
index ec5a3905b7..b4130e35fc 100644
--- a/development/inform/inform.info
+++ b/development/inform/inform.info
@@ -1,10 +1,10 @@
PRGNAM="inform"
-VERSION="6.34_6.12.2"
+VERSION="6.34_6.12.4_1"
HOMEPAGE="http://www.inform-fiction.org/"
-DOWNLOAD="https://slackware.uk/~urchlay/src/inform-6.34-6.12.2.tar.gz \
+DOWNLOAD="https://slackware.uk/~urchlay/src/inform-6.34-6.12.4-1.tar.gz \
http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/designers_manual_4.zip \
http://www.ifarchive.org/if-archive/infocom/compilers/inform6/manuals/IBG.pdf"
-MD5SUM="c5ef293adb9d245975ca5aa3af2bdef8 \
+MD5SUM="b128a7aff7ed2b1086d020febae20746 \
0063968c3378636add1a0697b6d1fc16 \
b2635d3d61313bed286409500fc55bed"
DOWNLOAD_x86_64=""
diff --git a/development/inform/parallel_make.diff b/development/inform/parallel_make.diff
new file mode 100644
index 0000000000..f2c13267ce
--- /dev/null
+++ b/development/inform/parallel_make.diff
@@ -0,0 +1,20 @@
+diff -Naur inform-6.34-6.12.4-1/Makefile inform-6.34-6.12.4-1.patched/Makefile
+--- inform-6.34-6.12.4-1/Makefile 2020-08-02 20:37:10.000000000 -0400
++++ inform-6.34-6.12.4-1.patched/Makefile 2020-11-05 00:32:19.772575474 -0500
+@@ -67,7 +67,7 @@
+ $(CC) -o $(BINNAME) $(OBJECTS)
+ @echo "** Done building compiler."
+
+-%.z5: %.inf
++%.z5: %.inf $(BINNAME)
+ $(PWD)/$(BINNAME) +lib $< $@
+
+ demos: $(BINNAME) $(DEMO_Z5)
+@@ -115,6 +115,7 @@
+ install -c -m 644 $(wildcard ${TUTOR}/*) $(DESTDIR)$(TUTORDIR)
+
+ install-contrib:
++ install -d -m 755 $(DESTDIR)$(BINDIR)
+ install -c -m 755 contrib/pblorb.pl $(DESTDIR)$(BINDIR)
+ install -c -m 755 contrib/scanblorb.pl $(DESTDIR)$(BINDIR)
+ cd $(DESTDIR)$(BINDIR) ; ln -s pblorb.pl pblorb