summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Logan Rathbone2019-11-22 17:13:45 +0100
committer Willy Sudiarto Raharjo2019-11-22 17:13:45 +0100
commit12315a168343a9718507eeebe92549b302e4a618 (patch)
tree2b56895da93ce65772bc5f16792cf4ac009e2bb3
parentdfa01f979031114375c30bb7dad85f53b1507c4a (diff)
downloadslackbuilds-12315a168343a9718507eeebe92549b302e4a618.tar.gz
python/rencode: Added (Python module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/rencode/README7
-rw-r--r--python/rencode/rencode.SlackBuild99
-rw-r--r--python/rencode/rencode.info10
-rw-r--r--python/rencode/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/python/rencode/README b/python/rencode/README
new file mode 100644
index 0000000000..459886ec92
--- /dev/null
+++ b/python/rencode/README
@@ -0,0 +1,7 @@
+The rencode module is similar to bencode from the BitTorrent project.
+For complex, heterogeneous data structures with many small elements,
+r-encodings take up significantly less space than b-encodings.
+
+This version of rencode is a complete rewrite in Cython to attempt to
+increase the performance over the pure Python module written by Petru
+Paler, Connelly Barnes et al.
diff --git a/python/rencode/rencode.SlackBuild b/python/rencode/rencode.SlackBuild
new file mode 100644
index 0000000000..5536b6c31e
--- /dev/null
+++ b/python/rencode/rencode.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/sh
+
+# Slackware build script for rencode
+
+# Copyright 2019 Logan Rathbone <poprocks@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# CHANGELOG
+#
+# 20191118 Logan Rathbone <poprocks@gmail.com> 1.0.6-1
+# - Initial SlackBuild.
+
+PRGNAM=rencode
+VERSION=${VERSION:-1.0.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="COPYING README.md"
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ $DOCFILES \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/rencode/rencode.info b/python/rencode/rencode.info
new file mode 100644
index 0000000000..9edb293e6d
--- /dev/null
+++ b/python/rencode/rencode.info
@@ -0,0 +1,10 @@
+PRGNAM="rencode"
+VERSION="1.0.6"
+HOMEPAGE="https://github.com/aresch/rencode"
+DOWNLOAD="https://github.com/aresch/rencode/archive/v1.0.6/rencode-1.0.6.tar.gz"
+MD5SUM="5ad85007483c35d0d04c1e027a680f1c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Logan Rathbone"
+EMAIL="poprocks@gmail.com"
diff --git a/python/rencode/slack-desc b/python/rencode/slack-desc
new file mode 100644
index 0000000000..18e37f6c77
--- /dev/null
+++ b/python/rencode/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rencode: rencode (Python module for object serialization similar to bencode)
+rencode:
+rencode: rencode is a Python module for fast (basic) object serialization
+rencode: similar to bencode from the BitTorrent project.
+rencode:
+rencode: This version of rencode is a complete rewrite in Cython to attempt to
+rencode: application on one of these lines, but it's not necessary.
+rencode: increase the performance over the pure Python module written by Petru
+rencode: Paler, Connelly Barnes et al.
+rencode:
+rencode: Homepage: https://github.com/aresch/rencode