summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-10-26 17:59:08 +0200
committer Willy Sudiarto Raharjo2019-10-26 19:36:09 +0200
commit87442475f32a305c5a60a66badd56617dbd08d65 (patch)
tree8f52110a45edbd93459a27feb36e895870319360
parentd6c9363ab25000458e4df97761b5dd07b28f2b05 (diff)
downloadslackbuilds-87442475f32a305c5a60a66badd56617dbd08d65.tar.gz
python/blessings: Added python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/blessings/blessings.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/blessings/blessings.SlackBuild b/python/blessings/blessings.SlackBuild
index b6a2e52c96..26423fad6d 100644
--- a/python/blessings/blessings.SlackBuild
+++ b/python/blessings/blessings.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for blessings
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=blessings
VERSION=${VERSION:-1.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true