summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Yth - Arnaud2019-10-26 13:49:15 +0200
committer Willy Sudiarto Raharjo2019-10-26 13:52:04 +0200
commit5d4fff9048051f19ea7ce05177d3c767434c8938 (patch)
tree3ed8aeb1c79b51024c4a8be547d571b3648b073d
parentd90dcde49f4f672fe41e216aa6d4b07a7883f724 (diff)
downloadslackbuilds-5d4fff9048051f19ea7ce05177d3c767434c8938.tar.gz
python/Kallithea: Added (Source Code Management System).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/Kallithea/Kallithea.SlackBuild68
-rw-r--r--python/Kallithea/Kallithea.info10
-rw-r--r--python/Kallithea/README7
-rw-r--r--python/Kallithea/slack-desc19
-rw-r--r--python/Kallithea/versions.patch68
5 files changed, 172 insertions, 0 deletions
diff --git a/python/Kallithea/Kallithea.SlackBuild b/python/Kallithea/Kallithea.SlackBuild
new file mode 100644
index 0000000000..d2f7bc265f
--- /dev/null
+++ b/python/Kallithea/Kallithea.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# SlackBuild script for Kallithea.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Kallithea
+VERSION=${VERSION:-0.4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cat $CWD/versions.patch | patch -p1 || exit 1
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.rst CONTRIBUTORS LICENSE* MANIFEST.in MIT* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Kallithea/Kallithea.info b/python/Kallithea/Kallithea.info
new file mode 100644
index 0000000000..3b4a9893c6
--- /dev/null
+++ b/python/Kallithea/Kallithea.info
@@ -0,0 +1,10 @@
+PRGNAM="Kallithea"
+VERSION="0.4.1"
+HOMEPAGE="https://kallithea-scm.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/K/Kallithea/Kallithea-0.4.1.tar.gz"
+MD5SUM="73b9fd1aa456313d004e342398735580"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cffi alembic waitress WebOb FormEncode SQLAlchemy Mako Pygments babel python-dateutil Markdown docutils dulwich decorator bleach click bcrypt Whoosh celery URLObject Routes Paste Beaker WebHelpers TurboGears2 tgext.routes backlash gearbox"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/Kallithea/README b/python/Kallithea/README
new file mode 100644
index 0000000000..82fbaaba90
--- /dev/null
+++ b/python/Kallithea/README
@@ -0,0 +1,7 @@
+Kallithea, a member project of Software Freedom Conservancy, is a GPLv3'd,
+Free Software source code management system that supports two leading
+version control systems, Mercurial and Git, and has a web interface that is
+easy to use for users and admins.
+
+You can install Kallithea on your own server and host repositories for
+the version control system of your choice.
diff --git a/python/Kallithea/slack-desc b/python/Kallithea/slack-desc
new file mode 100644
index 0000000000..fcf29e76d1
--- /dev/null
+++ b/python/Kallithea/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Kallithea: Kallithea (Source Code Management System)
+Kallithea:
+Kallithea: Kallithea, a member project of Software Freedom Conservancy,
+Kallithea: is a GPLv3'd, Free Software source code management system that
+Kallithea: supports two leading version control systems, Mercurial and Git,
+Kallithea: and has a web interface that is easy to use for users and admins.
+Kallithea:
+Kallithea: You can install Kallithea on your own server and host repositories
+Kallithea: for the version control system of your choice.
+Kallithea:
+Kallithea:
diff --git a/python/Kallithea/versions.patch b/python/Kallithea/versions.patch
new file mode 100644
index 0000000000..9c9c1e6849
--- /dev/null
+++ b/python/Kallithea/versions.patch
@@ -0,0 +1,68 @@
+diff -c a/setup.py b/setup.py
+*** a/setup.py 2019-03-31 21:31:17.000000000 +0200
+--- b/setup.py 2019-06-12 15:39:28.093303343 +0200
+***************
+*** 37,67 ****
+ requirements = [
+! "alembic >= 0.8.0, < 1.1",
+ "gearbox < 1",
+! "waitress >= 0.8.8, < 1.2",
+! "WebOb >= 1.7, < 1.8", # turbogears2 2.3.12 requires WebOb<1.8.0
+ "backlash >= 0.1.2, < 1",
+! "TurboGears2 >= 2.3.10, < 2.4",
+ "tgext.routes >= 0.2.0, < 1",
+ "Beaker >= 1.7.0, < 2",
+ "WebHelpers >= 1.3, < 1.4",
+ "FormEncode >= 1.2.4, < 1.4",
+! "SQLAlchemy >= 1.1, < 1.3",
+! "Mako >= 0.9.0, < 1.1",
+! "Pygments >= 2.0, < 2.3",
+ "Whoosh >= 2.5.0, < 2.8",
+! "celery >= 3.1, < 4.0", # celery 4 doesn't work
+! "Babel >= 1.3, < 2.7",
+! "python-dateutil >= 1.5.0, < 2.8",
+! "Markdown >= 2.2.1, < 2.7",
+ "docutils >= 0.11, < 0.15",
+ "URLObject >= 2.3.4, < 2.5",
+! "Routes >= 1.13, < 2",
+ "dulwich >= 0.14.1, < 0.20",
+! "mercurial >= 4.1.1, < 4.10",
+! "decorator >= 3.3.2, < 4.4",
+! "Paste >= 2.0.3, < 3.1",
+! "bleach >= 3.0, < 3.1",
+! "Click >= 7.0, < 8",
+ ]
+
+ if sys.version_info < (2, 7):
+--- 37,67 ----
+ requirements = [
+! "alembic >= 0.8.0",
+ "gearbox < 1",
+! "waitress >= 0.8.8",
+! "WebOb >= 1.7",
+ "backlash >= 0.1.2, < 1",
+! "TurboGears2 >= 2.3.10",
+ "tgext.routes >= 0.2.0, < 1",
+ "Beaker >= 1.7.0, < 2",
+ "WebHelpers >= 1.3, < 1.4",
+ "FormEncode >= 1.2.4, < 1.4",
+! "SQLAlchemy >= 1.1",
+! "Mako >= 0.9.0",
+! "Pygments >= 2.0",
+ "Whoosh >= 2.5.0, < 2.8",
+! "celery >= 3.1, < 4.0", # celery 4 doesn't work
+! "Babel >= 1.3",
+! "python-dateutil >= 1.5.0",
+! "Markdown >= 2.2.1",
+ "docutils >= 0.11, < 0.15",
+ "URLObject >= 2.3.4, < 2.5",
+! "Routes >= 1.13",
+ "dulwich >= 0.14.1, < 0.20",
+! "mercurial >= 4.1.1",
+! "decorator >= 3.3.2",
+! "Paste >= 2.0.3",
+! "bleach >= 3.0",
+! "Click >= 7.0",
+ ]
+
+ if sys.version_info < (2, 7):