summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-09-23 18:42:08 +0200
committer Willy Sudiarto Raharjo2019-09-28 12:40:07 +0200
commit998acc712f0a4411b724d2fcda173262ca5c205d (patch)
tree63ccb1a87c6f852cf384ba04ce368a1f98a12def
parent2ac8c1eda2b071b73c48aaba136537f03aa1fa28 (diff)
downloadslackbuilds-998acc712f0a4411b724d2fcda173262ca5c205d.tar.gz
python/pygame: Added python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/pygame/README2
-rw-r--r--python/pygame/pygame.SlackBuild6
2 files changed, 8 insertions, 0 deletions
diff --git a/python/pygame/README b/python/pygame/README
index a5a5eb6337..960d796ba9 100644
--- a/python/pygame/README
+++ b/python/pygame/README
@@ -2,3 +2,5 @@ Pygame is a set of Python modules designed for writing games. It is written
on top of the excellent SDL library. This allows you to create fully
featured games and multimedia programs in the python language. Pygame is
highly portable and runs on nearly every platform and operating system.
+
+Optional dependency: python3
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 36c5397ee2..89cd4697eb 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -82,6 +82,12 @@ python -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
+# Pythonn 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ CFLAGS="$SLKCFLAGS" \
+python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true