summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Fernando Lopez Jr2019-07-04 02:27:26 +0200
committer Willy Sudiarto Raharjo2019-07-04 02:27:26 +0200
commit2500d823a8769d84111f803b23fc874255ea64c2 (patch)
treec311b59b8896e41556cdce8a118d99b7771a81ee
parent9a474b7d3dd818701f7e68d029fcad7f6bc3ea42 (diff)
downloadslackbuilds-2500d823a8769d84111f803b23fc874255ea64c2.tar.gz
python/ebaysdk: Added (SDK to eBay API).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/ebaysdk/README4
-rw-r--r--python/ebaysdk/ebaysdk.SlackBuild76
-rw-r--r--python/ebaysdk/ebaysdk.info10
-rw-r--r--python/ebaysdk/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/python/ebaysdk/README b/python/ebaysdk/README
new file mode 100644
index 0000000000..8623ed4980
--- /dev/null
+++ b/python/ebaysdk/README
@@ -0,0 +1,4 @@
+This SDK is a programatic inteface into the eBay APIs. It
+simplifies development and cuts development time by standerizing
+calls, response processing, error handling, debugging across
+the Finding, Shopping, Merchandising, & Trading APIs.
diff --git a/python/ebaysdk/ebaysdk.SlackBuild b/python/ebaysdk/ebaysdk.SlackBuild
new file mode 100644
index 0000000000..7eaf58ed3c
--- /dev/null
+++ b/python/ebaysdk/ebaysdk.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for ebaysdk
+
+# Copyright 2019 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ebaysdk
+VERSION=${VERSION:-2.1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ Changes INSTALL README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/ebaysdk/ebaysdk.info b/python/ebaysdk/ebaysdk.info
new file mode 100644
index 0000000000..9a6c19b9eb
--- /dev/null
+++ b/python/ebaysdk/ebaysdk.info
@@ -0,0 +1,10 @@
+PRGNAM="ebaysdk"
+VERSION="2.1.5"
+HOMEPAGE="https://pypi.org/project/ebaysdk"
+DOWNLOAD="https://files.pythonhosted.org/packages/db/7f/53245710a67cb9de1ad2a0e78c012c6e6e327b05dc8fb4b2e85a7ef0220b/ebaysdk-2.1.5.tar.gz"
+MD5SUM="91a9a81c3b553ef808ad3a391f5a0bfe"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/ebaysdk/slack-desc b/python/ebaysdk/slack-desc
new file mode 100644
index 0000000000..4a252ca135
--- /dev/null
+++ b/python/ebaysdk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ebaysdk: ebaysdk (SDK to eBay API)
+ebaysdk:
+ebaysdk: This SDK is a programatic inteface into the eBay APIs. It simplifies
+ebaysdk: development and cuts development time by standerizing calls, response
+ebaysdk: processing, error handling, debugging across the Finding, Shopping,
+ebaysdk: Merchandising, & Trading APIs.
+ebaysdk:
+ebaysdk:
+ebaysdk:
+ebaysdk:
+ebaysdk: