summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-05-17 08:24:26 +0200
committer Willy Sudiarto Raharjo2019-05-18 02:22:18 +0200
commit56e56491d0c5c0f613ab2bc5ca58fa83251f4b42 (patch)
tree539e9a3ca80d584988b532d2daee12b3075807da
parent76b3f6ab4c8b1bb1e1dd316c930ec7afa8a0afa1 (diff)
downloadslackbuilds-56e56491d0c5c0f613ab2bc5ca58fa83251f4b42.tar.gz
development/jupyter-widgetsnbextension: Updated to use Python 3.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--development/jupyter-widgetsnbextension/jupyter-widgetsnbextension.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/development/jupyter-widgetsnbextension/jupyter-widgetsnbextension.SlackBuild b/development/jupyter-widgetsnbextension/jupyter-widgetsnbextension.SlackBuild
index f459cb788e..258158e3d6 100644
--- a/development/jupyter-widgetsnbextension/jupyter-widgetsnbextension.SlackBuild
+++ b/development/jupyter-widgetsnbextension/jupyter-widgetsnbextension.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter-widgetsnbextension
-# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
SRCNAM=widgetsnbextension
PRGNAM=jupyter-$SRCNAM
VERSION=${VERSION:-3.4.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true