summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2019-03-13 20:42:19 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:33 +0100
commita29134952d64f540d7a372c335c741d5accef33c (patch)
tree84af3bdfb1c857e5686fc0e6fb97a9c063a23be0
parentbe8f5f20b31c5acabc1ffc058d7e0faaf7d762e5 (diff)
downloadslackbuilds-a29134952d64f540d7a372c335c741d5accef33c.tar.gz
python/gunicorn: Updated for version 19.9.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/gunicorn/README2
-rw-r--r--python/gunicorn/gunicorn.SlackBuild9
-rw-r--r--python/gunicorn/gunicorn.info6
3 files changed, 12 insertions, 5 deletions
diff --git a/python/gunicorn/README b/python/gunicorn/README
index df43680025..fc0fbf951c 100644
--- a/python/gunicorn/README
+++ b/python/gunicorn/README
@@ -3,3 +3,5 @@ It's a pre-fork worker model ported from Ruby's Unicorn project.
The Gunicorn server is broadly compatible with various web
frameworks, simply implemented, light on server resource usage,
and fairly speedy.
+
+Optional dependency (autodetected): python3
diff --git a/python/gunicorn/gunicorn.SlackBuild b/python/gunicorn/gunicorn.SlackBuild
index 4be0679634..f84d970bb7 100644
--- a/python/gunicorn/gunicorn.SlackBuild
+++ b/python/gunicorn/gunicorn.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gunicorn
-# Copyright 2016-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gunicorn
-VERSION=${VERSION:-19.8.0}
+VERSION=${VERSION:-19.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/gunicorn/gunicorn.info b/python/gunicorn/gunicorn.info
index 550c8e7336..a16cdb68a1 100644
--- a/python/gunicorn/gunicorn.info
+++ b/python/gunicorn/gunicorn.info
@@ -1,8 +1,8 @@
PRGNAM="gunicorn"
-VERSION="19.8.0"
+VERSION="19.9.0"
HOMEPAGE="https://gunicorn.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/ac/92/a906209497d6391ef8826bc2e5d8d7b164d7c6253cc8bda36bf03a8d0161/gunicorn-19.8.0.tar.gz"
-MD5SUM="e64872dc5f09726627ee5946d881eb3b"
+DOWNLOAD="https://files.pythonhosted.org/packages/47/52/68ba8e5e8ba251e54006a49441f7ccabca83b6bef5aedacb4890596c7911/gunicorn-19.9.0.tar.gz"
+MD5SUM="f581937e9d8569ebd3fd6af1f9ab809f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""