summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky2019-03-15 01:10:03 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:27 +0100
commit766d6e8b15163986fac7630ce75389cf74ce866e (patch)
treef76915fff7a5ac3ba398033010e039cc2840b232
parentcfa49bddac5bdc64853ef1bec34af09ceb8e4d48 (diff)
downloadslackbuilds-766d6e8b15163986fac7630ce75389cf74ce866e.tar.gz
graphics/scantailor-advanced: Added (post-processing tool).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--graphics/scantailor-advanced/README14
-rw-r--r--graphics/scantailor-advanced/doinst.sh13
-rw-r--r--graphics/scantailor-advanced/scantailor-advanced.SlackBuild114
-rw-r--r--graphics/scantailor-advanced/scantailor-advanced.info10
-rw-r--r--graphics/scantailor-advanced/slack-desc19
5 files changed, 170 insertions, 0 deletions
diff --git a/graphics/scantailor-advanced/README b/graphics/scantailor-advanced/README
new file mode 100644
index 0000000000..bc9f041e8e
--- /dev/null
+++ b/graphics/scantailor-advanced/README
@@ -0,0 +1,14 @@
+ScanTailor is an interactive post-processing tool for scanned pages. It
+performs operations such as:
+ * page splitting,
+ * deskewing,
+ * adding/removing borders,
+ * selecting content
+ * ... and others.
+You give it raw scans, and you get pages ready to be printed or
+assembled into a PDF or DjVu file. Scanning, optical character
+recognition, and assembling multi-page documents are out of scope of
+this project.
+
+The ScanTailor version that merges the features of the ScanTailor
+Featured and ScanTailor Enhanced versions, brings new ones and fixes.
diff --git a/graphics/scantailor-advanced/doinst.sh b/graphics/scantailor-advanced/doinst.sh
new file mode 100644
index 0000000000..aea0f894eb
--- /dev/null
+++ b/graphics/scantailor-advanced/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/graphics/scantailor-advanced/scantailor-advanced.SlackBuild b/graphics/scantailor-advanced/scantailor-advanced.SlackBuild
new file mode 100644
index 0000000000..9a07e6a768
--- /dev/null
+++ b/graphics/scantailor-advanced/scantailor-advanced.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/sh
+
+# Slackware build script for scantailor-advanced
+
+# Copyright 2019, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=scantailor-advanced
+VERSION=${VERSION:-1.0.16}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i \
+ -e 's/^cmake_minimum_required.*$/cmake_minimum_required(VERSION 3.5.2)/' \
+ -e 's/^find_package(Boost 1.60 REQUIRED/find_package(Boost 1.59 REQUIRED/' \
+ -e 's/^set(CMAKE_CXX_STANDARD 17)$/set(CMAKE_CXX_STANDARD 14)/' \
+ CMakeLists.txt
+
+sed -i 's/>Deksew:</>Deskew:</' \
+ translations/scantailor_*.ts ui/SettingsDialog.ui
+
+mkdir -p build
+cd build
+ cmake -G "Unix Makefiles" \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+sed -i -e 's/Icon=ScanTailor/Icon=ScanTailor-Advanced/' \
+ $PKG/usr/share/applications/scantailor.desktop
+mv $PKG/usr/bin/scantailor $PKG/usr/bin/scantailor-advanced
+mv $PKG/usr/share/applications/scantailor.desktop \
+ $PKG/usr/share/applications/scantailor-advanced.desktop
+mv $PKG/usr/share/icons/hicolor/scalable/apps/ScanTailor.svg \
+ $PKG/usr/share/icons/hicolor/scalable/apps/ScanTailor-Advanced.svg
+mv $PKG/usr/share/mime/packages/scantailor-project.xml \
+ $PKG/usr/share//mime/packages/scantailor-advanced-project.xml
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/scantailor-advanced/scantailor-advanced.info b/graphics/scantailor-advanced/scantailor-advanced.info
new file mode 100644
index 0000000000..6883eb99ea
--- /dev/null
+++ b/graphics/scantailor-advanced/scantailor-advanced.info
@@ -0,0 +1,10 @@
+PRGNAM="scantailor-advanced"
+VERSION="1.0.16"
+HOMEPAGE="https://github.com/4lex4/scantailor-advanced"
+DOWNLOAD="https://github.com/4lex4/scantailor-advanced/archive/v1.0.16/scantailor-advanced-1.0.16.tar.gz"
+MD5SUM="1011e3ed6fe0e65fcedc25389a29bd23"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="qt5"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/graphics/scantailor-advanced/slack-desc b/graphics/scantailor-advanced/slack-desc
new file mode 100644
index 0000000000..6e56222d78
--- /dev/null
+++ b/graphics/scantailor-advanced/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+scantailor-advanced: scantailor-advanced (post-processing tool for scanned pages)
+scantailor-advanced:
+scantailor-advanced: ScanTailor is an interactive post-processing tool for scanned pages.
+scantailor-advanced:
+scantailor-advanced:
+scantailor-advanced:
+scantailor-advanced:
+scantailor-advanced: Homepage: https://github.com/4lex4/scantailor-advanced
+scantailor-advanced:
+scantailor-advanced:
+scantailor-advanced: