summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2019-03-13 17:26:56 +0100
committer Willy Sudiarto Raharjo2019-03-16 00:53:25 +0100
commit11a1af722b4aa08fd1bb5c67524127c562de12ff (patch)
tree4002c612848c90d1a26b44929f820a10c791a7d6
parentd117632796e9bfbdd1cd6fb5b761e37afae3391c (diff)
downloadslackbuilds-11a1af722b4aa08fd1bb5c67524127c562de12ff.tar.gz
python/yarl: Added (Yet another URL library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/yarl/README6
-rw-r--r--python/yarl/slack-desc19
-rw-r--r--python/yarl/yarl.SlackBuild84
-rw-r--r--python/yarl/yarl.info10
4 files changed, 119 insertions, 0 deletions
diff --git a/python/yarl/README b/python/yarl/README
new file mode 100644
index 0000000000..30ca86a3c1
--- /dev/null
+++ b/python/yarl/README
@@ -0,0 +1,6 @@
+yarl (Yet another URL Library)
+
+The module provides handy URL class for url parsing and changing.
+
+yarl is python3 only. Thus, the dependency idna must be built
+in python3.
diff --git a/python/yarl/slack-desc b/python/yarl/slack-desc
new file mode 100644
index 0000000000..6db5460542
--- /dev/null
+++ b/python/yarl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+yarl: yarl (Yet another URL library)
+yarl:
+yarl: The module provides handy URL class for url parsing and changing.
+yarl:
+yarl: https://yarl.readthedocs.io/en/stable/
+yarl:
+yarl:
+yarl:
+yarl:
+yarl:
+yarl:
diff --git a/python/yarl/yarl.SlackBuild b/python/yarl/yarl.SlackBuild
new file mode 100644
index 0000000000..1635108324
--- /dev/null
+++ b/python/yarl/yarl.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for yarl
+# Copyright 2019 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=yarl
+VERSION=${VERSION:-1.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst docs/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/yarl/yarl.info b/python/yarl/yarl.info
new file mode 100644
index 0000000000..bc9f9b5b3d
--- /dev/null
+++ b/python/yarl/yarl.info
@@ -0,0 +1,10 @@
+PRGNAM="yarl"
+VERSION="1.3.0"
+HOMEPAGE="https://yarl.readthedocs.io/en/stable/"
+DOWNLOAD="https://github.com/aio-libs/yarl/archive/v1.3.0.tar.gz"
+MD5SUM="be1f160ce1711056aa54e1089a74a6e1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="idna python3-multidict"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"