summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-10-05 05:42:24 +0200
committer Willy Sudiarto Raharjo2018-10-06 02:25:24 +0200
commite567ef466545941ead91eb6b90a4d34178b8d62b (patch)
tree1c9e316c18e9fc51df6d685a8228a3ca446a1564
parent9b2ede649be0778bae9e9a489535fef0be73ff1c (diff)
downloadslackbuilds-e567ef466545941ead91eb6b90a4d34178b8d62b.tar.gz
python/testpath: Updated for version 0.4.1.
-rw-r--r--python/testpath/setup.py2
-rw-r--r--python/testpath/testpath.SlackBuild7
-rw-r--r--python/testpath/testpath.info8
3 files changed, 9 insertions, 8 deletions
diff --git a/python/testpath/setup.py b/python/testpath/setup.py
index 9fc1264e45..3a92914bf1 100644
--- a/python/testpath/setup.py
+++ b/python/testpath/setup.py
@@ -3,7 +3,7 @@ from setuptools import setup, find_packages
setup(
name='testpath',
- version='0.3',
+ version='0.4.1',
description='Test utilities for Python code working with files and commands',
url='https://github.com/jupyter/testpath',
author='The Jupyter Development Team',
diff --git a/python/testpath/testpath.SlackBuild b/python/testpath/testpath.SlackBuild
index c75ea3f921..1cdecb92b9 100644
--- a/python/testpath/testpath.SlackBuild
+++ b/python/testpath/testpath.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for testpath
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=testpath
-VERSION=${VERSION:-0.3.1}
+VERSION=${VERSION:-0.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,7 +70,8 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cp $CWD/setup.py .
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/testpath/testpath.info b/python/testpath/testpath.info
index d229e50049..eb7f65d6cb 100644
--- a/python/testpath/testpath.info
+++ b/python/testpath/testpath.info
@@ -1,10 +1,10 @@
PRGNAM="testpath"
-VERSION="0.3.1"
+VERSION="0.4.1"
HOMEPAGE="https://github.com/jupyter/testpath"
-DOWNLOAD="https://github.com/jupyter/testpath/archive/0.3.1/testpath-0.3.1.tar.gz"
-MD5SUM="b39b572b7e22570e679b924b6ed2dcdc"
+DOWNLOAD="https://github.com/jupyter/testpath/archive/0.4.1/testpath-0.4.1.tar.gz"
+MD5SUM="559a3068cd33a73c50578ae46741890b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"