summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2018-10-12 15:04:53 +0200
committer Willy Sudiarto Raharjo2018-10-12 15:07:27 +0200
commitbfa972910afb64587c133d1782086f218f90a7d1 (patch)
tree7f34d94055eb78a150ea6deac3083ab0a727372c
parent1908f3fcd85736e9f14f22d3810e7583ccd7c3bd (diff)
downloadslackbuilds-bfa972910afb64587c133d1782086f218f90a7d1.tar.gz
python/python-nbxmpp: Added python3 support.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-nbxmpp/python-nbxmpp.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/python-nbxmpp/python-nbxmpp.SlackBuild b/python/python-nbxmpp/python-nbxmpp.SlackBuild
index 0b0076b1ae..0fa96f1e80 100644
--- a/python/python-nbxmpp/python-nbxmpp.SlackBuild
+++ b/python/python-nbxmpp/python-nbxmpp.SlackBuild
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true