summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-10-08 05:32:52 +0200
committer Willy Sudiarto Raharjo2018-10-13 03:03:03 +0200
commit1ffc4da77ce21b851bb6dbb8fe01638a8b8d411b (patch)
tree91cd5fb4de55ab2340c1b82cb5d9d1d669103a1d
parent7558a3d2f0a7759c99354205607193fc3c08b659 (diff)
downloadslackbuilds-1ffc4da77ce21b851bb6dbb8fe01638a8b8d411b.tar.gz
python/entrypoints: Add Python 3 support.
-rw-r--r--python/entrypoints/entrypoints.SlackBuild7
-rw-r--r--python/entrypoints/entrypoints.info2
2 files changed, 5 insertions, 4 deletions
diff --git a/python/entrypoints/entrypoints.SlackBuild b/python/entrypoints/entrypoints.SlackBuild
index 19970b4334..5f6d246cc6 100644
--- a/python/entrypoints/entrypoints.SlackBuild
+++ b/python/entrypoints/entrypoints.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for entrypoints
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=entrypoints
VERSION=${VERSION:-0.2.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,7 +70,8 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cp $CWD/setup.py .
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/entrypoints/entrypoints.info b/python/entrypoints/entrypoints.info
index 7e455a452b..a7963e4eae 100644
--- a/python/entrypoints/entrypoints.info
+++ b/python/entrypoints/entrypoints.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/takluyver/entrypoints/archive/0.2.3/entrypoints-0.2
MD5SUM="ad31adbe634709555c400de125098dc8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"