summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo2024-03-31 19:33:45 +0200
committer Willy Sudiarto Raharjo2024-04-05 10:18:15 +0200
commit9dc13520927d7b2ef3107a94b4966aec9669ab76 (patch)
treece07c29f0c155d32604cf1730bf5d6e2be681ae9
parent34795d10f933098937fa50a33e5022bef3fa71de (diff)
downloadslackbuilds-9dc13520927d7b2ef3107a94b4966aec9669ab76.tar.gz
python/python3-lsp-server: Fix PYTHONPATH.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-lsp-server/python3-lsp-server.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/python/python3-lsp-server/python3-lsp-server.SlackBuild b/python/python3-lsp-server/python3-lsp-server.SlackBuild
index d0cc6752a3..665f899d0d 100644
--- a/python/python3-lsp-server/python3-lsp-server.SlackBuild
+++ b/python/python3-lsp-server/python3-lsp-server.SlackBuild
@@ -87,7 +87,8 @@ sed -i "s|pyflakes>=2.5.0,<2.6.0|pyflakes>=2.5.0|" -i pyproject.toml
sed -i "s|pylint>=2.5.0,<3|pylint>=2.5.0|" -i pyproject.toml
# Use newer, non-stock setuptools due to package requirements
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl