summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Hunter Sezen2019-08-24 02:23:32 +0200
committer Willy Sudiarto Raharjo2019-08-24 02:23:32 +0200
commit85c0c5cf11271d29b2141c3d2745dc95dfc7ba6e (patch)
tree032c8d1ec6fd67e5588309c07c863781fdba450c
parent4d1fce68801fb022fcf3597b5c6b5b6806bab981 (diff)
downloadslackbuilds-85c0c5cf11271d29b2141c3d2745dc95dfc7ba6e.tar.gz
games/zelda-xd2-mercuris-chess: Added (Parodic Zelda fangame).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/zelda-xd2-mercuris-chess/README4
-rw-r--r--games/zelda-xd2-mercuris-chess/doinst.sh9
-rw-r--r--games/zelda-xd2-mercuris-chess/install.patch95
-rw-r--r--games/zelda-xd2-mercuris-chess/slack-desc19
-rw-r--r--games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.SlackBuild76
-rw-r--r--games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.info10
6 files changed, 213 insertions, 0 deletions
diff --git a/games/zelda-xd2-mercuris-chess/README b/games/zelda-xd2-mercuris-chess/README
new file mode 100644
index 0000000000..ed7ec0788a
--- /dev/null
+++ b/games/zelda-xd2-mercuris-chess/README
@@ -0,0 +1,4 @@
+Zelda XD2: Mercuris Chess is the sequel of the first XD parodic game,
+and was also released on April 1st, in 2017 this time. As a direct
+sequel, the overworld is expanded, the story is extended and the funny
+tone is kept, if not bettered!
diff --git a/games/zelda-xd2-mercuris-chess/doinst.sh b/games/zelda-xd2-mercuris-chess/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/games/zelda-xd2-mercuris-chess/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/zelda-xd2-mercuris-chess/install.patch b/games/zelda-xd2-mercuris-chess/install.patch
new file mode 100644
index 0000000000..9ddf925897
--- /dev/null
+++ b/games/zelda-xd2-mercuris-chess/install.patch
@@ -0,0 +1,95 @@
+From be770ecd2fb902d0e7080663890d9f01ca3bb84b Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Mon, 19 Aug 2019 15:03:52 -0700
+Subject: [PATCH 1/2] Add a desktop file.
+
+---
+ CMakeLists.txt | 5 +++++
+ zelda-xd2-mercuris-chess.desktop | 9 +++++++++
+ 2 files changed, 14 insertions(+)
+ create mode 100644 zelda-xd2-mercuris-chess.desktop
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 890919b..74b50fc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -76,3 +76,8 @@ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${quest_name}
+ DESTINATION ${SOLARUS_INSTALL_BINDIR}
+ )
+
++# FreeDesktop compatible start menu launcher
++if(UNIX AND NOT APPLE)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/zelda-xd2-mercuris-chess.desktop
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
++endif(UNIX AND NOT APPLE)
+diff --git a/zelda-xd2-mercuris-chess.desktop b/zelda-xd2-mercuris-chess.desktop
+new file mode 100644
+index 0000000..0a8d339
+--- /dev/null
++++ b/zelda-xd2-mercuris-chess.desktop
+@@ -0,0 +1,9 @@
++[Desktop Entry]
++Name=Zelda XD2: Mercuris Chess
++GenericName=Zelda fangame for the Solarus engine
++Comment=Zelda XD2: Mercuris Ches (Parodic Zelda game)
++Exec=zelda_xd2_mercuris_chess
++Terminal=false
++Type=Application
++Icon=zelda_xd2_mercuris_chess
++Categories=Game;AdventureGame;
+--
+2.22.0
+
+From 0912e4d1c0f235fcc6470bd163bd3e5144377d49 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Mon, 19 Aug 2019 15:12:41 -0700
+Subject: [PATCH 2/2] Install icons.
+
+---
+ CMakeLists.txt | 30 ++++++++++++++++++++++++++++++
+ 1 file changed, 30 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 74b50fc..297205d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -76,6 +76,36 @@ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${quest_name}
+ DESTINATION ${SOLARUS_INSTALL_BINDIR}
+ )
+
++# FreeDesktop compatible icons
++if(UNIX AND NOT APPLE)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_16.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_20.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/20x20/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_22.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/22x22/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_32.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/32x32/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_40.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/40x40/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_48.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/48x48/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_64.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/64x64/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_96.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/96x96/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_128.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/128x128/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_256.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/256x256/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_512.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/512x512/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/icon_1024.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/1024x1024/apps RENAME zelda-xd2-mercuris-chess.png)
++ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/data/logos/logo_2x.png
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/pixmaps RENAME zelda-xd2-mercuris-chess.png)
++endif(UNIX AND NOT APPLE)
++
+ # FreeDesktop compatible start menu launcher
+ if(UNIX AND NOT APPLE)
+ install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/zelda-xd2-mercuris-chess.desktop
+--
+2.22.0
+
diff --git a/games/zelda-xd2-mercuris-chess/slack-desc b/games/zelda-xd2-mercuris-chess/slack-desc
new file mode 100644
index 0000000000..f4cbf78911
--- /dev/null
+++ b/games/zelda-xd2-mercuris-chess/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+zelda-xd2-mercuris-chess: zelda-xd2-mercuris-chess (Parodic Zelda fangame)
+zelda-xd2-mercuris-chess:
+zelda-xd2-mercuris-chess: Zelda XD2: Mercuris Chess is the sequel of the first XD parodic game,
+zelda-xd2-mercuris-chess: and was also released on April 1st, in 2017 this time. As a direct
+zelda-xd2-mercuris-chess: sequel, the overworld is expanded, the story is extended and the funny
+zelda-xd2-mercuris-chess: tone is kept, if not bettered!
+zelda-xd2-mercuris-chess:
+zelda-xd2-mercuris-chess: Homeage: https://www.solarus-games.org/
+zelda-xd2-mercuris-chess:
+zelda-xd2-mercuris-chess:
+zelda-xd2-mercuris-chess:
diff --git a/games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.SlackBuild b/games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.SlackBuild
new file mode 100644
index 0000000000..12ce84d177
--- /dev/null
+++ b/games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for The Legend Of Zelda XD2: Mercuris Chess
+
+# Copyright 2018-2019 Hunter Sezen California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=zelda-xd2-mercuris-chess
+VERSION=${VERSION:-1.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-v$VERSION
+tar xvf $CWD/$PRGNAM-v$VERSION.tar.gz
+cd $PRGNAM-v$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Add a desktop file and install the hicolor icons.
+# https://gitlab.com/solarus-games/zelda-xd2-mercuris-chess/merge_requests/102
+patch -p1 < $CWD/install.patch
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSOLARUS_INSTALL_BINDIR:PATH=games \
+ -DSOLARUS_INSTALL_DATADIR:PATH=share/games/solarus \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a changelog.txt license.txt readme.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.info b/games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.info
new file mode 100644
index 0000000000..8bed9c5d71
--- /dev/null
+++ b/games/zelda-xd2-mercuris-chess/zelda-xd2-mercuris-chess.info
@@ -0,0 +1,10 @@
+PRGNAM="zelda-xd2-mercuris-chess"
+VERSION="1.1.1"
+HOMEPAGE="https://www.solarus-games.org/"
+DOWNLOAD="https://gitlab.com/solarus-games/zelda-xd2-mercuris-chess/-/archive/v1.1.1/zelda-xd2-mercuris-chess-v1.1.1.tar.gz"
+MD5SUM="73eb42a4297727f7b52e08aaeef2db5e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="solarus"
+MAINTAINER="Hunter Sezen"
+EMAIL="orbea@riseup.net"